So, what's your Linux week been like?

Employed my Raspberry Pi 1 B+ as a print server in the last few weeks. It’s working great for Windows, Linux and Android devices. Although I’m getting this annoying “Bad Request” error when connecting to CUPS via hostname rather than IP so I’m not sure what that’s about.

I’ve been doing a bit of looking at self hosting a push notification provider for my de-Google Android phone. Seems like another task for my Nextcloud server once that’s set up again after moving. And I’ll probably be switching over my LineageOS to Lineage with signature spoofing so I can install microG as well. Should be interesting!

EDIT: I spoke too soon. The print server suddenly doesn’t print a dang thing. Using a Brother HL-L2320D that normally wouldn’t have any network capabilities. Worked perfect for a week now no pages print even though CUPS reports the job completes and the status light on the printer blinks. Ooof!

Just started a new job at a VFX studio as SysAdmin. The environment is primarily macOS & Linux. Compared to my old job as IT Analyst for a hotel, I’ve never felt so in control. Before, I had to call vendors if I need something fixed, or go through a lot of red tape. Now, I can make those changes myself, and can always consult my IT teammates if I need any help. And I’m not just the IT of 1 location, as I’m also supporting other offices.


Well done.

1 Like

Congrats. Spend your free time reading the man pages. Report it as training and research. Reap the harvest.


This week I’ve been connecting to a remote site over OpenVPN, and testing out which methods of file access of a (Linux OpenMediaVault) fileserver are fastest. I needed to do common things like browse large folder structures for interesting files, download files in bulk, search for files remotely, and estimate total folder sizes (recursively totaling up all sub-folders as well).

Here are my findings, after several hours of tinkering:

  • Syncthing is the all-around fastest, if you have write access over a (very large) remote folder you’d like to copy in bulk (Syncthing needs to create a zero-size hidden file in any remote folder you want to sync). Synthing is especially fast when you have many tiny files to copy, like a bunch of ebooks, or smallish documents/spreadsheets. But be warned there is a considerable learning curve to Syncthing; best used by geeks only. Not for “normies”. :wink:
  • Filezilla is great for fast browsing around in a huge folder structure. FTP-over-TLS is as blazing fast as Syncthing for file transfers, but chokes as soon as soon as there are any Unicode chars in the filenames/folder names (potential fix here for the proftpd server of OpenMediaVault). Filezilla can also do SFTP, which has no Unicode problems - very peppy for folder browsing - but slower (than Syncthing or FTP) for larger file transfers.
  • For remotely searching for files, nothing beats just SSH’ing into the remote server and using fdfind on the command line.
  • For remotely estimating total folder sizes, a very fast and fun ncurses-based folder-size calculating app is “ncdu”. Again, SSH in to use it.
  • SMB/CIFS browsing/previewing/downloading/searching/filesize totallings always sucked very badly for speed, over OpenVPN. :-1: Avoid!

If you just want one app to do it all, Filezilla wins as all-around best goto app, IMHO.

1 Like

This week I learned how to use Virt-manager (Virtual Machine Manager). There was a learning curve, to get the installation .iso attached to a new VM, and the virtual networking, but now that I’ve played with it for a while using a test VM, I’m quite impressed.

@esbeeb Were you using any other VMs prior? such as VirtualBox? I’m curious about the learning curve from a noobie view point vs someone who is crossing over.

I have past experience with Oracle Virtualbox, and VMware Workstation, and disliked both of them (they get too naggy over time with marketing, or upgrades to the host software breaks guest VMs). Last time I tried Gnome “Boxes”, it was really immature.

I noticed that Gnome Boxes has a flatpak now (perhaps has matured since I tried it about 2 years ago), but I didn’t want to waste about 1GB of SIM card to try it, when the virt-manager-related downloads were just a few hundred MB total.

I think gnome-boxes has matured a lot since then. I used it about a month ago just to check it out because I had a discussion about the program on another website, and after trying it out for a little bit, I don’t really use it religiously like I do virt-manager, but it has the benefit of being able to spin up a vm really quickly in comparison

1 Like

Yeah it’s not bad, I set my wifes Pop os install up with Windows 7 on gnome-boxes … it works really well , my wife is stoked she can use her old Photo editing software (Picture it).

This week I took a look at webmin 2.0, for remote administration of a Debian server with no desktop environment.

A non-technical user will probably hate it, as it has an overwhelming number of things you can change. There is no hiding of more advanced or rarely-used features within “Advanced” tabs, expanding options, etc. Like the most common things are not brought out to the forefront, simplifying what you see at first, while inviting you to dig deeper if you are a really geeky user. A good GUI shows only 3-7 choices at a time.

Having said this, I, for one, really appreciated it, because so many things I saw have far, far more ugly places you need to know about and change on the command line - the sorts of stuff that grizzled Unix admins only come to know about after many years of battle-hardened field experience.

Great examples:

  • the ability to graphically allow or deny lists of users for SSH login:

  • The Bell icon on the right informs you there are security updates to install, then you can do that graphically.

Edit: there is a system of marking various places as favorites (click the stars), so I was able to find the 7ish things I would probably actually use on a regular basis:

This serves to simplify things somewhat.

1 Like

Have you tried Cockpit? If so, how does it compare?

I took a quick look at cockpit (as packaged for Debian 11, ver 239-1), but decided to go back to Webmin.

Here are my thoughts, comparing the two:

Cockpit has better packaging in Debian 11: it was just an “apt install” away. (Webmin, in contrast, was a .deb downloaded from dodgy sourceforge servers - but there is an md5sum to verify authenticity).

Cockpit’s UX was like 10x cleaner and more consistent than webmin. Cockpit’s UX was a much more modern web app (webmin will hurtle you into the past by 10 or 20 years… forget using webmin from a smartphone). Redhat did a good job designing Cockpit, albeit Cockpit has far fewer features (for example, I can’t find any place to monitor /var/log/syslog), than webmain. Like not enough features to cover all the basics. Webmin’s too many features (or at least, poorly-organized features from a UX perspective) are preferable to me, rather than having not enough features.

While it was possible to install a pre-1.0-release file manager into Cockpit, it had nowhere the maturity and feature-completeness, that the bundled file manager had in Webmin.

Webmin’s bundled file manager alone made it worth using! It had tabs, bookmarks (to favorite folders), RESTful URLs, etc.

Although Cockpit’s killer feature was the ability to administer podman containers, I highly doubt that it can do all the admin and maintenance features that a real-world admin would actually end up needing to use, over the longer term. A real-world admin will likely have to drop down to the command line anyway, to do all the things which cockpit doesn’t accommodate - so it’s sort of useless to use Cockpit at all if it doesn’t cover everything you’d need. I’m unaware of even one person (of the fellow geeks I know) who manages podman containers long term (like say, for 3 years running, even doing security updates, backups/restores, etc), entirely from Cockpit (or from Cockpit whatsoever).

Anyone out there, who loves and uses podman from Cockpit, and never needs to drop down to the CLI?

Not over here. I eventually (pretty quickly) ended up just using the terminal and ignoring the Cockpit Podman interface.

1 Like

cockpit isn’t a Red Hat project, it’s a project sponsored by Red Hat. It’s worth considering because despite dropping sponsorship of virt-manager the project continues on and the same will probably be true of cockpit.

I’m not sure how far cockpit’s progressed but it’s been somewhat bare compared to virt-manager for some time. Though being fair… virt-manager is the most comprehensive VM GUI experience i’m aware of though it’s not a webpage interface.

1 Like

Actually, once I got a feel for how secure Webmin is, it’s setting off my sketch-O-meter to the point where I’ve decided not to use it anymore. I saw obfuscated javascript where it has no right existing. It looked (to my non-security-expert eye) suspiciously like a backdoor.

I was also turned off by:

  • how there is no RSS feed of security updates for webmin
  • the use of Sourceforge whatsoever. Come on, it’s 2022, and there’s really no excuse these days to still be using Sourceforge any longer, I say.
  • the heavy use of Perl, which is harder to security-audit (not to mention it’s harder to write secure code in, in the first place).
  • this super-sketchy backdoor discovery in webmin back from 2019. I suspect such backdoors still exist!
  • how it used to be included in Debian repos, but got kicked out; not DFSG-compliant.

Thanks for the input. I don’t run any containers at the moment so that’s no trouble for me. I found a third party plugin for managing samba shares and permissions that worked well. Cockpit is pretty extendible if the plugin exists.

Woke up today to having a muted icon floating around on my desktop on both monitors. Hmmmm.

My sound is piped out to bluetooth speakers in the office. That system was NOT muted. What?!?

I updated the system yesterday. Did it include any updates to the sound libraries? No.

Maybe this is related to a browser? Nope. Videos play with sound in all browsers.

I gave up and had to leave for “real” work. While I was out, I had the thought that I need to look at the PIDs that are running and I will find the culprit.

I stopped by my desk in a couple of hours and noticed that the screens were blank (expected experience) but the icon was still floating around on the blank screens. Ah Ha! I then had the idea that this is a monitor icon not a system icon.

Sure enough! The monitors I use have built in speakers that I never utilize. Somehow, they decided to start showing the muted icon. Problem solved. I was reminded that effective troubleshooting involves a step by step walk through of EVERY contributing system.


This week I’m taking some baby steps learning podman. I’m one of these crusty curmugeons who doesn’t want to have to learn a whole new operating system - which is what the linux container ecosystem effectively is.

I feel like this is the late 90’s again. Does anyone remember how dodgy the website was back in the day? To find super janky .rpm packages, which might have come from any one of 10ish Redhat knockoff distros? Finding containers are like that: a janky wild goose chase around different sites which tease you into believing you can download containers from them without being subjected to torture.

For example, where could I download a Heimdall container?

podman pull

worked. But not:

podman pull linuxserver/heimdall:latest

… like this page would have you believe (in the top right corner). And yes, I even logged into my dockerhub account in podman.