So, what's your Linux week been like?

As I lay here at 24 minutes past midnight it’s now Saturday 5th October. and in the last week I have been enjoying my Linux.

  1. I installed Manjaro 18.1 on a SSD partition on an HP EliteBook 8470p laptop. I went the Xfce route and everything went fine. The install was fast, simple and it’s been running nicely. I’ve used it some part of every day since I installed it (and my usual packages). I’ve done my typical mix of things, no problems (it’s not the most complex mix of things but then most home users probably don’t).
  2. I installed the latest SolydXK 10 (the X for Xfce version) on my other HP EliteBook 8470p (yes, I have 2, one has Arch based distros, one has Debian based). Apart from the eye straining orangeness of the themes (the dark version is OK I guess, but still boring) it’s a very nice, easy to install Debian 10 (Buster) based distro. It does have it’s own repos but mostly uses the Debian ones and is pretty close to a Debian install.
  3. And most importantly, I’ve kept my MX Linux 19 beta 2.1 updated while waiting for the beta3 or Release Candidate to appear.

Those 3 distro have been in daily use, sharing the “stuff” I’ve been messing with. All three have been a joy and fun to use. SolydX is the one I have least experience with, I’ve used MX since the mid MX-17 cycle, Manjaro 18 I’ve had on another laptop and have kept up to date and played with about once a week since earlier this year (April? May? I forget). I had a brief flirtation with SolydX earlier this year, it lasted maybe a couple of days before the orange theme had me screaming. This time I changed the wallpaper and changed to a dark theme and got it to be a it more bearable, OK even (so, I’m picky, sue me).

As “I also did” tasks I made sure to keep the partition with SparkyLinux 6 (semi-rolling), Debian Testing (Bullseye), ArcoLinux, and EndeavourOS updated, gave them a little exercise each (an hour or so between mugs of tea and biscuits). All-in-all I had a good week.

What I continue to notice also is, once you get past the installers, and the themes, and start using the applications, how they all work well, they are all just… well, Linux. I suppose if you have very new (or maybe very old) kit, or you have specific specialist software needs (I’ll include gaming in that, I’m not a gamer) you may be a bit more selective, but I could live and get by happily, with these and other distros.

We are spoiled compared to when I first tried Linux about the turn of the millenium, so muny good distros, so much choice… and yes, I know that can be see as a problem for getting new adoptions, but that’s a different discussion.

It’s now 3 minutes to 1am, I’m going to try and get some sleep


I learned a process running in the terminal can usually be suspended using CTRL + Z. It’s then listed under the jobs command and can be resumed by using fg or in the background using bg if it’s the only job. Otherwise you append the job id after a %, example: bg %2

Linux processes, init, fork/exec, ps, kill, fg, bg, jobs - YouTube


Handy, aint it? You can also put jobs in the background by appending & on the command line (best they don’t need keyboard input) - hand for scripts.

I know odds and ends and forget about them until something make me think - thinking too much makes my head hurt :smile:


A hassle.

Google has been acting in a difficult manner towards my yadifa DNS servers: yadifa does this optimization, without asking me, to create pointer records when more than one hostname has the same IP address.

But then Google mail servers won’t receive email from my totally legitimate domain any longer, hating on those pointer records.

So I’ve written an ugly hack script to make sure yadifa doesn’t do its clever optimization (my script makes sure to undo the pointer records, should they ever get created), and doesn’t upset Google’s ultra-meticulous DNS record requirements.

Other than that, my MX Linux 18 laptop works like a charm.

I’m also doing a careful upgrade of Nextcloud on two of my servers. To ver. 17? No, upgrading from ver. 15 to 16. I’m conservative that way.

1 Like

I had to DuckDuckGo “yadifa DNS” and I’m wondering, “do you need yadifa for some special reason?”. I mean if you have to hack a script to undo what it does, why use it? I guess I don’t understand what it does, why it does it, and why I’ve not heard of it - curiosity.

1 Like

My Linux week?
Just using the system for work and play. :slight_smile: In my case Mageia 7.1. Working excellently.

1 Like

No I don’t have to use yadifa, but I hate BIND9 even more. Yadifa is a modern implementation of a DNS server, but it’s a little too clever for it’s own good. I wouldn’t pick yadifa again, if I had to do it all over again, but now that it’s in place, and it was very hard to initially set up (it does some sophisticated DNSSEC setup for you), I’m just going to stay the course for now, until some kind of proper fix can be done.

1 Like

Ahhh, the old “I wouldn’t do it again but now it’s done I aint changing it” thing, been there, done that, didn’t waste my money on the t-shirt…


Good -n- Bad.

The bad: No This Week in Linux has not appeared on BitChute. (Start Calling it This Bi-Weekly in Linux :smile:)

The Good. Finally was able to get through Linux From Scratch for the first time after getting frustrated two times before. Finally, a basic booting Linux OS I built by hand.


I am looking forward to building 9.0 too, will probably do both versions (non-systemd and systemd), even more importantly its BLFS where things will really get interesting for me because my background is in coding not sys-admin.

I wonder if you’re going to journey into BLFS? Also which version of LFS did you build and how long did it take?


I started way back on the version 7.x series then would quit after a while. It is a very tidious process to do it all by hand. I have also experienced the case of people who actually involved in making something, and are the ones who make the documentation, tend not to do a very good job when looking at the perspective of someone who has never looked at the thing which they are presenting to us. With that, there was also some confusion, and not so clear areas for me as I had not done them.

I finally pushed through version 8.4 Systemd. What I decided to do this time was to create a text document where I would document all the commands I would be entering into this text document. I also labeled them. This made things a bit clearer, and if I made a mistake, was easier to find out what went wrong. So yes, I was able to quickly find mistakes I made to correct them, then be on my way again. It also allows for easier tracking of your progress.

It took a long time to complete. There are only about ~80 files to compile, but some of them will have to be built differently a few times. I am not sure how long it took maybe a typical work week?

I am now redoing it, but now with version 9.0 systemd. It is going much faster as many of the packages are either the same, or with minor updates. So I can just copy from the old text file to the new on in most cases now. I chose systemd because it is the future, and those init scripts are dead, and not the way to go.

Here is a nice talk given about systemd

After I complete 9.0 systemd , I will be going into BLFS. I need to learn all this if I want to bring back a dead Linux Distro which was killed off some years ago.

PS: This Week in Linux still not appeared on BitChute.


TWIL was pushed to podkicker as normal 6 days ago so not sure what the issue is with BitChute

1 Like

Yeah, the site seems to be getting worse. Maybe switch over to JoshWhoTV where I am seeing actual improvements than regressions like on BitChute

1 Like

Twice a year I always do a pilgrimage to the new Ubuntu release, which for me was not the first Linux environment I ever used but it is the OS I’ve used the most.I’ll stick with Gnome for a couple of weeks and maybe try another flavor later. So far so good.


Oct 8 I used the experimental ZFS installer for Ubuntu 19.10. I installed Ubuntu 19.10 on ZFS in Virtualbox on sdb, while sda has Ubuntu 19.10 on ext4 with both zfsutils-linux and zfs-initramfs installed. The installer refused to install a boot loader on both sda and sdb, but after booting from ext4 and:

updating /etc/default/grub
update-grub and grub-install /dev/sda

I have a nice dual boot system in Virtualbox :slight_smile: And now forwards up to the next experiments. Ubuntu 19.10 on ZFS uses almost twice the memory of the ext4 version, mainly because of L1ARC (memory cache) :slight_smile:

The main advantages of zfs compared to ext4 are:

  • no file corruption during crashes or power fails,
  • LZ4 compression reducing size and number of disk IO operations by a factor two,
  • snapshots with ~1 second response times,
  • memory and SSD caching
  • complete and proven raid support

This release has limited practical use for me, because the current version wipes the whole disk during installation and it does not yet support raid configurations. I already have 3 PCs booting from ZFS (from partitions and from raid-0) using some trickery with 18.04, 19.04 and even 19.10 (my install not the official install). On both of my systems I use partitions, for my SSD; half as boot device and half as L2ARC (SSD cache). Besides I like to put the Virtual Machines at the begin of the HDDs, because the disk throughput is often twice as high there.
With a single large SSD the system will work fine with these limitations, but remember it is experimental.

Oct 10: I tried to work with snapshots and that is not easy, because of the complex dataset structure used by Ubuntu. I have created a snapshot and I did see a possibility in the Grub menu to revert to the snapshot and it seemed to work. The current system is saved and the system rolls back to the snapshot before booting. Your system size will double, because this type of backup of the current system is not supported by ZFS, so a complete back up must be made. For standard ZFS a roll-back is a roll-back and it deletes anything done after the snapshot used as target in the roll-back.

Oct 11: Of course for ZFS there is very good documentation, but for the Ubuntu add-ons there is absolutely no documentation, so you are restricted to guessing or try and error. Today I worked some time with the system without any issue. There are still issues with the installer, many people report problems and for me the Xubuntu install failed both today and yesterday. It seems that I was lucky with my Oct 8 install. Upto now I produced ~5 bug reports on mostly minor issues.


It’s been all black and white for me…I’ve been coding data extracts from API’s in Python and then writing Ansible playbooks to automate the data extracts…all in VIM.


You fail your masochist test, you should have used emacs…

1 Like

emacs? Blasphemy, I say !!!


You don’t want the masochist award?

I am ok using either Emacs or Vim :slight_smile: