Yet Another Lesson About Booting Linux via USB

As in: this was me learning yet another lesson. Sigh. Oh well, I am here to share the tale.

This time I was setting up two systems, one was going onto a 32GB thumb drive for myself, the other onto a 500GB SSD for a friend.

With both, the install all went as usual, up to the point where the install media would be removed and a reboot done into the newly built system.

Neither worked. And neither worked on another computer either. Both computers normally work for my various USB3 builds, both hard drives and thumb (i.e. memory) drives. But now, the EFI firmware of neither computer could “see” the drives at all for booting.

Cue much Internet research. Eventually I tried plugging the new builds into the USB2 port - suddenly all was fine.

The catch it seems is that neither computer’s firmware can recognise a USB 3.1 device, hence these are not presented as boot options. By comparison, an operating system running on the same computers can happily see the drives.

Now as it happens, I had this happen a few years ago, in that I had one Western Digital USB3 drive that I similarly couldn’t get to boot. As it was just one drive, I simply used it for regular storage instead - but now I’m thinking it may have encountered this same syndrome.

As is common for manufacturers, this (now old) computer is on its latest - and last - firmware update, from many years ago, so I don’t expect any firmware fix to suddenly show up.

The takeaways from this:

  • always try the USB2 port if something doesn’t work on the USB3 port
  • at least I can use this thumb drive to test a potential purchase machine (well, in-store at least)
  • now I have some investigation to do to find a suitable method of using a post-firmware boot loader to recognise and execute the thumb drive and thus run it on USB3 instead of USB2.

It’s also interesting that because I was making something using the exact same process that I had previously used successfully many times, when it didn’t work I initially assumed that somehow what I produced was different. It wasn’t - instead my computer had been sitting there, unable to see a USB 3.1 device at boot all this time, and I just didn’t know that.