Web browsers can't find my certificates on KDE Neon (Ubuntu) 22.04

I’ve tried the following applications:

  • Firefox (Snap)
  • Vivaldi (DEB)
  • Edge (Flatpak)

I placed them on both /etc/pki/ca-trust/source/anchors/ & /etc/ssl/certs/ and ran update-ca-certificates. Any ideas what I’m missing?

Edge (Flatpak) on my Rocky Linux 9 works fine.

I think it is likely something to do with KDE Neon. Maybe they updated something causing an issue. I personally recommend people avoid Neon because it is designed for developers and testers and not daily usage. I know their website says “Ideal for everyday users” on the user edition but their FAQ also says it is not a distro and they do not put any effort towards the base system and only care about the KDE stack. That is such an absurd mixed message that I highly recommend people avoid that and use Kubuntu instead.

I am curious about the Flatpak version of FIrefox though since it is maintained by Mozilla and with Flatseal you can mess with the permissions of it.

I tested with the apt version of Vivaldi on both KDE Neon and Tuxedo OS.

I put the root and immediate certificate crt files in /usr/local/share/ca-certificates/, and no dice. I did try to manually import on my Firefox (snap) using the same certificates and that worked.