Ubuntu Core 22, prototype of snap based immutable OS

I run, that Ubuntu Core 22 in Virtualbox 7.08, after converting the pc.img file to a vdi file. For me Ubuntu Core is potentially the most important addition of Canonical to Linux, since Ubuntu 4.10 :slight_smile: A snap based immutable OS, not a compromise like a semi-immutable OS with 2 images, one to run and another one to be updated. I’m very curious, how things will develop for 24.04. I have the feeling, that it will be till 26.04 before it gets close to being perfect.
See the Core VM on my desktop.

The following picture show the workshop, where I created an Ubuntu 22.04 container and a Ubuntu 20.04 VM. Basically they all open up in the terminal and there is no desktop GUI yet.

A screenshot from the lxc container running. See the memory usage :slight_smile:

An view of the Sofware (Snap) Manager and the terminal running in Core OS.

I tried to use the Ubuntu print screen key to create the picture, but only the Core OS reacted to the key presses and all my screenshots were stored in the Core OS folders. I could not transfer those files to the Host, because the installation of VBox Guest Additions failed of course. I had to install another screenshot app in the host :slight_smile:

I’m from May 1945 and I have the feeling that I have to learn a lot of new stuff the coming years (AI, snap based immutable OS; Cloud integration). The last 10 years were easy to follow, most software changes were about the bling-bling. Anyhow I like to try out some stuff:

  • I want to try to install Guest Addition. I already tried it using tty3 the root terminal, mount the ISO file and giving my group access to the folders needed by Guest Additions, but it still refused to write those vbox guest additions files. I’ll try it again.
  • I might have to use samba or USB to enable file exchanges.
  • I like to try to install a xubuntu desktop in the VM running in the Core VM.
  • I need more time to look at setting up a container or a VM, the parameters during creation are still very limited, e.g one core, but there is a list with say 30 very technical parameters. I have a look at modifying those parameters too.
  • I have no clue about the cloud versions and need some time with it.
  • Try to use virt-manager or boxes to integrate the VM with the workshop, if allowed :slight_smile: ) Maybe the VMs are immutable too.
1 Like

Very interesting. Thanks for the recap of what you’ve found.

Progress Report 230712

  • I tried again to install Virtual Guest Additions as root in tty3, but that failed on a VBox mkdir in /opt and /var/lib. The error message was “read only file system”, so I did give it up.
  • My Host OS got samba access from the Core22 VM. The Core22 VM is the server. So I can exchange files now. It directly worked without any issue, probably Core22 is more intended as server :frowning:
  • The install of the xubuntu desktop worked fine for the 20.04 VM in the workshop of Core 22, however the Xserver had issues and did not start. I like to retry with only xfce, look what happens.
  • That list of 30 technical parameters, I could not change them; e.g increasing the number of cores for the VM to 2 was refused with syntax error.
  • I installed Boxes the simple virtual machine manager using “snap install gnome-boxes” in tty3. It appears in the app overview of Core22 and it starts and looks fine. However I run into issues with the 12GB size of the Core22 disk, the free space is not big enough for even an ISO file. I had to increase the vdi disk size with Virtualbox to 40GB and I increased the size of the last partition with gparted to fill the new space.
  • However playing with Boxes I got constant permission errors, while all file and folder permission seem correct, even selecting VMs from the boxes internal download list ended with permission errors. However I detected that my userid was missing from the /etc/passwd list and also no user was displayed in the User tab of Settings, the GUI app :slight_smile: Core22 seems to have a competing user administration.
  • For fun I installed Fedora 38 from the workshop overview and updated the OS by the command line to the latest 6.3 release, like always no GUI :slight_smile:

Giving the incompatibility of the user and permission handling, between Core22 and Ubuntu 2022 I skip this month and try again early August. I have the feeling that most problems I detected, could be related to it.