Ubuntu 22.04, Intermittent monitor problems

I’m running Ubuntu 22.04 LTS Gnome Wayland an MSI Bravo 15 Ryzen 7 4800H 15.6" 40GB A4DDR-212IN laptop. It’s about 2 years old. I just did a software update and reboot and the issue is still there.

In the past week or so the screen has been intermittently acting up. See here

to see exactly what’s going on. Anyone seen anything like this? Any ideas what’s going on and how to fix it? How can I run diagnostic tests on my graphics/screen stack?

Next time the problem happens, I’ll switch to X11 and see what that does.

Thanks! :innocent:

I don’t have experience with this particular problem but I would call this phenomenon “screen tearing.”

You might get closer to a solution with judicious search word selection. Such as:

AMD Screen Tearing
AMD Wayland MSI Screen Tearing

1 Like

One other possibility is that it could be a hardware issue. To test that you would just need to plug in an external monitor in mirrored mode, to see if they look the same or not.

1 Like

Yep, I got a spare monitor so if the problem happens again, I’ll test it. Hopefully won’t happen again.

I googled this and found some helpful info. Thanks.

@LinuxUser The problem happened again and I plugged in my spare monitor (HDMI cable). The problem was not happening on the external monitor. Does this narrow down where the problem is? If yes, could you give details? Thx!

To me that points to the issue being with either the internal laptop display or the cable that feeds it from the main board. Typically the cable runs through the laptop lid hinge and flexes each time that the lid is opened or closed. So it is possible that one or more of the wires is breaking or the cable is coming loose on one of the ends.

1 Like

@LinuxUser Great, thanks. Another person gave me this diagnosis and suggestions (see text below). Do they sound reasonable?

Don’t be surprised if the shop finds nothing wrong with the video cable. Your problem resembles corruption I’ve seen with various GPUs on various distros, often called tearing. Various combinations of hardware and software have bugs, and this is one of the types that gets past software developers’ own testing, particularly the driver writers it seems.

Disabling compositing may make the problem disappear, but it can come with a feature loss cost.

You could try using the modesetting DIX display driver instead of the amdgpu DDX display driver. Simply uninstall xserver-xorg-video-amdgpu and reboot. If it helps, you’re done if you want to be. If not, reinstall it or not, but communicate the issue to the developers of the amdgpu DDX driver for possible assistance.

Could my system get messed up if I uninstall xserver-xorg-video-amdgpu?

Would it be helpful if I tried switching from the IGPU to the AMD GPU and see what that does?

FYI: I’m using prime-select = on demand

FYI: The problem is still there when I switch to Xorg or when I boot from an Ubuntu USB ISO stik.

The reasons that I am leaning towards a hardware issue, is that you said it was intermittent and it doesn’t happen on a mirrored external display. If the problem were at the driver level then I would expect to see the corruption in the mirrored external display as well.

That being said, it would be prudent to test out all of the software options before you tear apart the laptop to rule them out.

As for using the modesetting driver, I don’t have any AMD laptops, so I don’t know for sure, but that seems correct. I do something similar on my Intel based laptops, uninstall the xserver-xorg-video-intel driver because it is recommended not to use it.