Ubuntu 21.04. Newbie here. Please confirm correctness before I do a Timeshift system restore

Newbie here. See pics. Some of my apps got messed up and I want to do a Timeshift system restore to yesterday (Aug 10th). Please look at the pics and see if I’m all set to do a restore. Will this restore take my apps back to yesterday? I want to make sure cuz I know a bad restore can trash my whole system. Thanks.

Should be good to go. I’ve used Timeshift to get out of a few sticky situations myself. From what I can see your home folder won’t be touched, only stuff outside of /home will be rolled back. Since I don’t know what the issue is, I cant tell you whether or not this is the right approach. If it’s a broken deb package that can’t be uninstalled (… this has happened to me), then a Timeshift restore is a good idea. If one specific app is misbehaving I might try finding it’s config files and moving them to a backup location to see if that fixes the problem first.
Best of luck anyway.

1 Like

Yes, this is my issue, 2 of my apps (Flameshot and KDEConnect) are not working and I can’t remove them. Is there a typical location where app config files are stored? Thx.

They are usually in the .config/ hidden directory. I generally use the find command if I’m not sure exactly what I’m looking for… Here’s a screnshot that shows where flameshot configuration files are on my system (Kubuntu 20.04)

This is essentially searching for anything in the current directory (my home folder) that has “flames” somewhere in the file name.

Also, since it looks like you’re trying to use KDE Connect with Gnome. have you looked at GSConnect (GSConnect - GNOME Shell Extensions)?

1 Like

OK, I found .config/flameshot/flameshot.ini. I just delete it?

Yep. The default configuration will be restored the next time you launch the app.

1 Like

I found all these other Flameshot files and directories. Some or all should be deleted? Yesterday I tried unsuccessfully to delete “apt Flameshot” and “flatpak Flameshot”. I would love to fully delete/remove/purge/nuke ALL vestiges of Flameshot and start over. That possible? Thanks.

If I delete ALL of these, will my system crash/die/blow up?


I’d try sudo apt remove flameshot --purge and flatpak remove org.flameshot.Flameshot --delete-data, assuming you installed the Flatpak and the version from the Ubuntu repo.

1 Like

Yep, that’s correct. I’ll try the commands you sent and report back soon.

So this command is all on one line? Or 2 separate commands? (Remember, I’m a newbie)
sudo apt remove flameshot --purgeandflatpak remove org.flameshot.Flameshot --delete-data

Two separate commands. First

  • sudo apt remove flameshot --purge

To remove the version from the Ubuntu repo, and then

  • flatpak remove org.flameshot.Flameshot --delete-data

to remove the flatpak.

1 Like

Here’s the results. Doesn’t look like it did much? Should I go ahead and just do the Timeshift system restore?

advait@advait-Bravo-15-A4DDR:~$ sudo apt remove flameshot --purge
[sudo] password for advait: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'flameshot' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
advait@advait-Bravo-15-A4DDR:~$ flatpak remove org.flameshot.Flameshot --delete-data
error: org.flameshot.Flameshot/*unspecified*/*unspecified* not installed

Looks like neither was actually installed. If you’re still having some kind of issue I’d try the Timeshift restore, but I’m not entirely clear on what the problem is.

1 Like

OK, just to double check, do I do the system restore from some kind of live usb? Or just do it from my normal Ubuntu system?

Just from the normal system. It will go through the process and then reboot automatically.

1 Like

OK, I’m taking a deep breath and hoping it works. I’ll report back soon.

Whoa! Looks like the restore worked! Very nice. Flameshot and KDEConnect now working again. Thanks for giving me the support and courage to do my first system restore. Now I’ll be doing system snapshots lots more before I install or update anything.

Only problem is VLC (snap) no longer working. UPDATE: I removed the VLC snap and installed the VLC flapak and now VLC seems to be working normally. Thanks for all your help!

1 Like