Time/Date problem on Manjaro

Hi all. I recently re-installed the latest Manjaro Budgie edition. I ran it for about 3 months and didn’t have this issue, but now I’m lost.

Manjaro itself is reporting the time and date correctly. I have NTP set up and no issues. My problem is that both Proton Mail and Facebook Messenger seem to think I sent or received an email or message 4 hours later than I did. For example, I received an email at 1149 Eastern, but Proton shows that it came in at 1649. As I’m typing this, it’s not yet even 1649. I have the same issues with FB Messenger. Both apps on my phone display the correct times. The really weird thing is that Proton Calendar shows the correct time.

When I first noticed it on Proton, I made sure that my settings there had the right time zone and it does. Same with Facebook. I’m using LibreWolf browser, if that makes any difference.

It’s not a life or death thing, just very annoying. If anyone can guide me in the right direction, I’d really appreciate it.


Have a look into the language setting of ProtonMail or even in LibreWolf. Could be that your browser is using the wrong locale? If you have another browser try to see if you see the same issue.

I’d try using a different browser on the same OS to help narrow the problem down.

You can also get the name of the timezone your browser is giving to Javascript by entering the following into the console:

Open console: Ctrl + Shift + J (makes sure “Console” tab is selected)


Okay, I tried Firefox and had no issues with the time. I ended up finding a post on Reddit. When I changed the flag mentioned in the post and restarted LibreWolf, all is good. Thanks for the input everyone!

I guess because I’m new to the forums, I can’t post a link or screenshot to where I found the solution.

1 Like

Just copy/paste the answer if possible or the part of the link after https://reddit.com/, you may also be able to encapsulate it between ` ` marks.

Good to hear things are working :slight_smile:

Okay, here’s the link:


Thank you, just helps if anyone else finds this.


  1. Open about:config in the address bar
  2. Search for: privacy.resistFingerprinting and set to false
  3. Restart if necessary

Source: https://www.reddit.com/r/LibreWolf/comments/muvzgd/browser_time_is_wrong/gv8r4gh/

That sounds like an unfortunate fix for Librewolf fans.