[Solved] UEFI Installation

Anyone know of any guides that walk you through any of the Ubuntu installs with UEFI?? I’d prefer to use XFS, but I’ve been using older computers and not having to deal with UEFI.

My big issue is Secure Boot and installing my nvidia drivers… I set the Secure Boot password (as asked) and then reboot - and get a blinking cursor after the Dell screen (Dell XPS 8910)

I would guess it’s the drive issue. You probably should of done the nVdia drivers last.

I’ve done it that way - I got everything installed ( base install using ext4 - not trying to change to XFS ) and logged in, etc - then when I install the nvidia drivers it says I need to give it a secure boot password - and then it reboots from the driver install and gives me the black screen with blinking __ cursor…

Over the last 36 hours I’ve installed it a few different ways… some have partially worked but everything fails with the Secure Boot stuff gets accessed for the driver install (even doing it up front in the install )

You may want to to have the system boot into single user mode where it will boot into text mode only. Then you can take a peek at the logs.

I suspect something about the configuration for using the nVidia drivers is not set correctly

You need to make sure the Secure Boot has your signing keys loaded.

Edit: Ubuntu should have set this up for you by rebooting into the UEFI’s key management utility.


This is the relevant documentation.

1 Like

Not sure if you’ve seen this post but it seems to have a very detailed procedure for fixing UEFI boot on this specific system - https://www.dell.com/community/XPS-Desktops/XPS-8910-cannot-add-UEFI-boot-option/td-p/6061673

This was it… I had never had the issue before because I’ve only installed 19.10 on my System76 laptop - which does NOT have nvidia graphics…

I didn’t know that after the install reboot there was something that needed to be done (enrolling the MOK) so I had actually missed it (and I don’t like that if you don’t pay attention, it times out and moves on without enrolling the MOK, which is what was causing my issues).

But the wiki did an OK job of explaining what I needed to do (although I had to make educated guesses at a couple of things in the MOK), but was able to do a successful install.

Today, I’ll be doing this all again on the 20.04 Beta for UM!!

1 Like

I’m glad I could point you to the right direction.

The first time I encountered that MOK screen I was very confused. It’s not the most intuitive process for sure.

1 Like