[SOLVED] Switched to Kubuntu - Need help w/ grub @ 30 sec & systemctl suspend failure

Hey DL,

I recently switched to Kubuntu and I’ve hit a few paper cuts. I’m wondering if any of you have experience trouble shooting two of the largest issues:

When I boot up, the machine will wait at the grub menu for 30 seconds. I’ve edited my grub to be 0 seconds, or 5 seconds on the timeout but nothing seems to be working after I do a sudo update-grub

Here’s my grub file:

GRUB_DEFAULT=0 GRUB_TIMEOUT_STYLE=menu GRUB_TIMEOUT=0 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo DebianGRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer" GRUB_CMDLINE_LINUX="nouveau.modeset=0"

I’ve tried nouveau.modest=1 as well or blacklisting nouveau. I’m running the 470 Nvidia driver as my Titan GTX X is recently out of support (or so I thought).

The second issue I’m seeing is that after I use the systemctl-suspend command, when I wake up the computer from sleep nothing is responsive. I can tell the machine wakes as the fans start up, my RGB keyboard lights up, but I can’t type commands and the screen is black. The keyboard is unresponsive so I can’t even drop to TTY or follow my shortcuts to open a terminal and reboot, etc.

I will note that sudo pm-suspend works perfectly, but it’s a pain to pass sudo every time rather than use a shortcut.

Anybody have any sage advice for these issues? My previous distro of several years on this machine never struggled with these particular problem points so it’s new territory for me.

Thank you!

What do you see when you enter the following in a terminal:

1 Like

I ran sudo dmesg after startup and this is what I see. Sorry, it’s a lot.

(pastebin removed)

Okay, so I think the issue I was having is that I do quite a few hard resets on my machine and GRUB has a fallback configuration for treating record fails. I foudn the info here: boot - Where to change 30 seconds for grub on forced reset - Ask Ubuntu

I had to add GRUB_RECORDFAIL_TIMEOUT=0 to my grub entry at /etc/default/grub and I believe that has solved the issue. I also changed my grub to the following:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

Because I want to hide the menu as well.

The most pressing issue for me now is that systemctl suspend doesn’t allow me to resume, but using sudo pm-suspend does!

I did a little more digging and found this article:

I followed the steps to disable the nvidia suspend, hibernate, and resume services and now systemctl suspend works perfectly!

Thanks for your attention to this issue.