So, what's your Linux week been like?

I don’t think I’ve posted on here for a very long time, because most of my weeks are much of a muchness, as it were. This previous week is going to go down in my journal as very significant. Apart from my humble contributions in the form of forum posts in the DLN community and strongly supporting the use of open source amongst family and friends, acting as hopefully an inspirational example myself…

This week I made my decision about which community to be a part of in terms of long-term commitment, hopefully including development work, and it is KDE :slight_smile:

I did my first KDE Community Wiki edit and triaged my first KDE bug and feel a contentment I have not felt in a very long time. I am wondering, as I progress on my bug triaging journey, which KDE application is going to prove just too irresistible and I’m going to want to work on its code?

Looking forward to it. Been a long time coming and I haven’t done a major project in C++ for some years now.

1 Like

I praise that, when somebody settles down and commits to a project such as KDE, even though that project might not be my own personal cup of tea.

That eventual “settling down” (having investigated the options enough, over time) is worth a lot, I say, to gain depth of understanding - not always being one who skims the surface, switching between things too often. People who have this depth of understanding become a “pillar” to that community in the longer run. This longer-run view is what makes for longevity that has a chance to outlast just one generation of users.

Unix was a heritage which the generation before mine handed down to me, but what handing down will there be to the generation after me?

1 Like

Thanks :slight_smile: I’m just getting my head around the basics, but I feel much more strongly connected to the spirit of open source now and yes, I hope to stick around. I’ve been eyeing-up accessibility as a potential area for development, but if it’s in need of quite a lot of heavy lifting, starting with smaller little contributions might help me establish myself better first, I think! All very exciting though!

I think Linux is here to stay, though I have to say I’ve very curious about that open source OS built using Rust. That might become very attractive in coming years. Also, as MS seem to be less and less interested in the desktop and more and more interested in the cloud, I wonder if just like Linux swept-aside Unix, if ReactOS will eventually replace Windows?

I run two systems from two 20GB partitions, one on the nvme (3400/2300MB/s) and another one on a 500GB Seagate HDD (135MB/s), that last one as a kind of backup. The nvme runs Ubuntu 21.10 and I have upgraded the HDD from Ubuntu 21.04 to 21.10 to 22.04, to try out the new release. Since I do my “work” in Virtualbox VMs from the nvme SSD, I see no difference running the Host OS from nvme or HDD, except for the initial boot time.

I had a problem during the upgrade to 22.04. I got a black screen, I let the system continue till the disk stopped working and using the recovery mode in the boot menu and its dpkg entry I got 22.04 working. Later I had the same black screen in a VM and on my laptop.

During the weekend a very annoying problem got solved. Displaying videos or VMs in full screen the top bar and dock flickered through the picture and it only disappeared after pressing the mouse keys a few times. That problem has been in 22.10 for a couple of months, but fortunately it disappeared in 22.04 during the updates over the weekend.

For the host OS I run 75% of the time in 22.04. Also for my communication Apps I use from time to time Xubuntu 22.04 instead of 20.04, but some programs (Whatsie & Caprine) do not appear in the bottom panel notification area, if I close the program unlike in 20.04. So I have to use the task manager to look whether they are still running. I still have to add KDE Connect to 22.04. Fortunately my Evolution with Email/Contacts/Tasks and Calendar work fine in 22.04. In 20.04 it refused to connect to the contacts during the last months.

Well tomorrow will be day 7 on Linux Mint with no distro hops. I decided to reward the team with a small donation. I’ve had no compelling reason to leave - and for me that’s significant.

Update - minor hiccup happened after a recent kernel update. I’d forgotten this Dell has SecureBoot enabled by default. The initial Mint install handled it fine but when the kernel didn’t match the expected key I got the “You must load the kernel first” error on boot. Turned off SecureBoot, and so far all is well.

1 Like

It’s amazing how no matter how nicely you think you have your linux servers all tweaked, and surely, this time, you can just leave them alone and they’ll just work, sure enough some subtle bugs emerge which take yet further tweaking.

This week I had to debug a subtle nginx config to make certbot happy for SSL cert auto-renewal.

PS: Handy command to ensure certbot will be happy at auto-renewal time, for all domains you get certbot SSL certs for:

sudo certbot --dry-run renew

They should look into whatever black magic Caddy does for certificates. No configuration required.

Sunday and Monday I moved completely to the Ubuntu 22.04 Beta. I have been using the dev.ed for some time and for many hours per day. I had a positive impression of its reliability, so I moved both Host-OSes and the VMs to the Beta.
I now use the following main VMs:

  • Xubuntu 22.04 LTS for all communication apps.
  • Ubuntu 16.04 ESM for Banking and PayPal. Firefox and LibreOffice are the latest snaps.
  • Ubuntu Studio 20.04 LTS for multimedia. I stayed on the xfce version, because I don’t like kde (too much frivolity).
  • Ubuntu 22.04 LTS for all try-outs and experiments.
  • Windows 11 Pro, just in case it is needed for something.

I now run a main Host-OS from my Silicon Power nvme-SSD (3400/2300MB/s; boot time = 26 secs) and a spare Host-OS from a Seagate HDD (135MB/s; boot time = 1 min 15 secs). Half of the 26 sec boot time is needed for mounting the 3 ZFS datapools, 2 datapools are on HDD. After booting there is no real difference anymore between both systems, since almost all work is run in the VMs from the nvme-SSD. Probably I could run the Host OS from an USB stick :slight_smile:

1 Like

I’ve been getting more into KDE Bugsquad bug triaging. I think I’ll go one app at a time, then when I’m much more confident, maybe switch focus to most recent incoming bugs across the project. Will take time, though! Also might get tempted into chipping in with some coding some way down the line, too. That would be even more fun, I think :slight_smile:

1 Like

I’ve been running this Acer Veriton super tiny PC for the last few months as a test system for work to learn Active Directory a bit better. It was running surprisingly well for a dual core as a remote desktop server but recently it has been very slow. Too many services added over time as I try things out is crushing the poor thing.

So I made some hardware available, installed openSUSE Tumbleweed and the Virtualization pattern. Made a VM for Windows Server 2022 and installed their new “Windows Admin Center” so I can manage nearly every aspect of that system from the browser. Then I installed Cockpit on oS Tumbleweed so I can manage it completely from the browser as well. So far that’s working really nicely but I really need to learn how to manage VMs from the terminal a bit better!

The next goal is to learn a bit more about docker/podman and run a nextcloud container on Tumbleweed to use for phone backups for my de-googled phone.

What to do with that ol’ Acer Veriton though? It’s the perfect HTPC so I thought Jellyfin or KODI but only the kids watch TV and it’s all Netflix or Disney+ and anything with a browser can do that. So I was thinking LMDE 5 so the kids could do their homework, SCRATCH programming and Netflix all on one machine. Then I can deprecate this Chrome Cast which has been the means of streaming shows to the TV up to now. So many choices…

Also this is the second time I thought I’d install openSUSE Leap, the server oriented version, on a server and ended up upgrading to Tumbleweed for simplicity. The first time Leap didn’t have a new enough Python3 version to do what I wanted it to do. This time Cockpit looked like a PITA to install on Leap where Tumbleweed just had the package in the repo. Talk about the fracturing of the Linux ecosystem, oS is a fracture within a fracture.

As I look at Ubuntu Studio 22.04 and their switch away from XFCE, I’m thinking about exploring how to keep XFCE with Ubuntu Studio 22.04. For that reason, I probably won’t be ready to install US 22.04 until the summer.

It sounds like a job for ubuntustudio-installer

Maybe install on an Xubuntu desktop?


After installation of Ubuntu Studio 22.04, try “apt install xubuntu-desktop” and purge the kde apps and kde desktop you do not want to use to save disk space.

1 Like

Backed up my server for World Backup Day. Tried to add my first program from the AUR on Manjaro…not a smooth experience. Using all my CPUs compiling czkawka and took 30-45 minutes with a Ryzen 5 2500U. Looks like it was compiling in a loop, so I canceled. Will have to try the Flatpak instead, once I remove…whatever it just did.

1 Like

Why is my 2003 Pentium 4 HT (1C2T; 3.0GHz) faster than my 2011 i5-2520 (2C4T; 2.5/3.2GHz)

Every Saturday I run the ZFS backup of my desktop to my backup-server and to my laptop, both running OpenZFS. I use Conky everywhere to display the internals! I use a 1 Gbps network. The backup to the Pentium runs constantly at ~22MB/s due to a load >90% on one CPU thread (sshd). The backup to the laptop runs sometimes at 85MB/s and than for seconds it halts running and often it drops to single digit numbers in the MB/s.

At the moment the transfer speed to the i5 collapses, I often see a 100% load in one or two of the CPU threads, while the frequency stays at 0.83 GHz and it stops or reduces the network transfer speed.

The Pentium uses 2 IDE disks and 2 laptop disks 3x 320GB and one IDE at 250GB. They are striped in two pairs. the IDE HDDs and the laptop HDDs. The load is constant and everything is predictable.

The laptop has one new 2TB Seagate ST2000LM007 HDD, bought on Ebay. It now has 11 power-on DAYS. The smart assessment says disk is OK, but I have 49 million seek errors and 146 million read errors. However all errors were recoverable. My desktop 500GB Seagate ST500DM002 HDD has 15 million read errors and 413 million seek errors in 8.5 power-on YEARS. I think it is explainable that a 2TB 2.5" HDD has more recoverable read errors than a 500GB 3.5" HDD, but 146 million in a 11 days seems very very high. Counting both seek and read errors, that is (49,000,000+146,000,000)/(11"24*3600)=205 errors/second.

The disk temperature is 49°C relatively high, but not unusual, since my 1TB WD Black from the desktop is running at 50°C. In an idle laptop the HDD temperature is 39°C. In the Caribbean the ambient temperature will be 32°C or more in the coming period.

Seagate Documents:
The drive should never exceed the temperature ranges below. If the drives ever exceed these temperature ranges then the drive is considered “overheated” or is not getting adequate air flow from your current case environment.
!! With our newer model drives the maximum temperature is now at 60°C.
The operating temperature range for most Seagate hard drives is 5 to 50 degrees Celsius. A normal PC case should provide adequate cooling.

For the STM2000LM007 Seagate specifies 60°C.

My theory: I bought a B-class HDD from Ebay, Seagate is bragging about the 60°C or the HDD temp read out is incorrect and too low. At least it seems the 2011 HP Elitebook can’t cool my 2TB HDD, creating too many recoverable errors. The HDD error recovery is done deep in the kernel in a mode that does not count to increase the CPU frequency, so the recovery happens at a low CPU frequency, that also worsens the throughput. Supporting arguments:

  1. If I increase the CPU frequency manually, the throughput is higher, but still hampered.
  2. The problems start to appear after 10 to 20 minutes in the backup :frowning:

During the next backup I will run the laptop from an old 160GB HDD and I will run the 2TB in open air on an USB 3.0 connection, close to my room fan :slight_smile:

I bought that 2011 HP laptop in early 2017 and it is now more than 10 years old. Time to swap it for another newer off-lease laptop, that has space for a modest nvme SSD and the cooling for a 2TB HDD.

I will never buy storage on Ebay again, I had a defect 250GB SSD; a defect 1TB SSHD and now these problems.

You use a mix of Linux and BSD right? This is a question for Allen Jude on the BSD Now podcast. They were saying on the last episode they didn’t get any new user questions so I bet they would answer right away.

Since June 2019 I run FreeBSD on the 2003 Pentium, but that oldie work perfectly. The problem is between two Ubuntu 22.04 machines with OpenZFS 2.1.
For the moment I assume it is a HDD temp problem, resulting in many errors due to the read head positioning in high temperatures.

In the past we would check the cylinder after each seek operation and if needed we would repeat the seek operation. With respect to read errors, in my deep past they started to introduce the possibility to give the read head a small off-set over the track. I calculated that my HDD need this type of recovery far too frequently (on average 205 recoveries/sec and the maximum ???).

I opened the desktop an hour ago and there is no ventilation in the neighborhood of the HDD, it even has a plastic cover. So my best guess is temperature, this 2011 HP laptop is not designed for 2TB HDDs. I did receive it with a 320GB HDD, which is now in the Pentium :slight_smile:

I’m probably way late to the party but I just discovered an unassuming app in my Linux Mint install called Hypnotix. It’s a desktop IPTV client for streaming, and apparently it lets me see broadcast TV from all over the world. I’ve only tested the USA, Japan and the UK feeds so far but it’s been a lot of fun. Kind of like having a reeeeeeallly big antenna on my house.

1 Like

Its great but I find a lot of Canadian channels just buffer forever.

I hit a weird problem this week - never heard of it before. LibreOffice Calc cut and paste suddenly wouldn’t work. Searching around on the net revealed it may be linked to some obscure KDE/Plasma bug. Sure enough, firing-up Gnome seemed to resolve the issue. Very strange, that. Has anyone else ever come across this?

Besides which, I’ve not really used Gnome recently at all, and it’s the first time I ran the “new” version since installing Debian 11. It certainly seems nippier than it was under Debian 10.

All of this is on a very old machine I finally had upgraded to 4GB from the 2GB it had, so I can finally multitask on it again, hurrah!