Slick Greeter (LightDM) showing black screen

My Slick greeter only shows black wallpaper by default, but when I run lightdm -d --test-mode, I see my wallpaper.

I applied the wallpaper using LightDM settings (lightdm-settings package from Ubuntu’s repo).

I had an issue that was almost the same… I changed the picture to a PNG file and it worked

Didn’t work :frowning:

try re-installing?

Open the config file with nano or micro or whatever terminal editor you prefer.

sudo micro /etc/lightdm/slick-greeter.conf

There should be a line for the wallpaper.


Just change that line to point to whatever you wish the image to be.

1 Like

Checked and it’s already changed.

If you have it correctly set up in the config, try purging the GUI you installed. It is not needed and may be introducing a conflict somewhere.

1 Like

Didn’t work :frowning:

$ sudo lightdm --show-config
A  allow-guest=false
C  greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
D  guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
J  greeter-session=slick-greeter
J  user-session=unity.desktop
H  xserver-command=X -core
I  type=xlocal
I  display-setup-script=/sbin/prime-offload
I  display-stopped-script=/sbin/prime-switch

B  backup-logs=false

K  background=/home/yamiyukisenpai/Pictures/19211116-2.png
K  theme-name=Yaru-dark
K  icon-theme-name=Yaru-dark
K  draw-user-backgrounds=false
K  other-monitors-logo=/home/yamiyukisenpai/Pictures/19211116-2.png
K  logo=/home/yamiyukisenpai/Pictures/19211116-2.jpg

A  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
B  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
C  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
D  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
E  /usr/share/lightdm/lightdm.conf.d/50-slick-greeter.conf
F  /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
G  /usr/share/lightdm/lightdm.conf.d/50-unity.conf
H  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
I  /usr/share/lightdm/lightdm.conf.d/90-nvidia.conf
J  /etc/lightdm/lightdm.conf.d/50-slick-greeter.conf
K  /etc/lightdm/lightdm.conf

I got the [Greeter] to show after renaming slick-greeter.conf that LightDM Settings created to lightdm.conf. Didn’t work :frowning: