Sharing Steam Library with Windows


I’m pretty new on Linux gaming - but it looks better all the time :slight_smile:
Have got an pretty large NTFS drive with Steam games - which I’m accessing from my Linux desktop.
It more or less works - BUT - having some weird things sometime where games I i.e. ran yesterday doesn’t work today.
Is’t normal?
Thanks :slight_smile: //Ted

1 Like

Any error messages when a game fails to start? Have you run any updates lately?

Sure - updates several times a week or as often as there’s any updates.
No, don’t think that there’s any useful error messages - maybe I’m not looking the right place?!

Best place is a journalctl -f when experiencing the error. If its a service or permission issue, it should show up in that.


I have never had great success running Steam on Linux and pointing to my Windows Steam Game Directory. I am not a massive gamer and therefore run a separate Linux Steam Library.

Well I’m for sure heading in the same direction - don’t want to waste time on a bad (temporary) decision.
Already had a look at gparted :wink:

Try installing ntfs-3g and mounting the drive.
I think this has SOMETHING to do with permissions / ownership.

But honestly? You can reduce the headache by just transferring all these game folders to your /home/.steam/steamapps/common/ folder!

1 Like

which will only work if you have a large enough home folder
linking to a secondary drive works - I have just found it does not work well when you first installed the game in windows and then tried to point Linux to that drive. Which I think is the current scenario ?

I’ve found out the solution to this, the hard way. Stuck me for months when I first came across to Linux earlier this year, so here’s the solution so you don’t have to suffer my pain:

Put the game libraries on an ext4 drive. Steam in Linux doesn’t like to run games, particularly those requiring Proton, from an NTFS partition. Even with the proper ntfs-3g driver installed and running (I could browse and write to the drive fine otherwise) it would NOT run games from it unless they were native, and even then not all the time.

For me, when I hit play it said “Running”, then a few seconds later it would just return to saying nothing, as if I hadn’t hit play at all.

Only when I made the effort to shift 1Tb of games from my NTFS hdd to my ext4 hdd did I see a difference, and it was an immediate difference at that. Games that refused to run, ran perfectly, as if they were native games.

Made a huge difference, so give that a go, because NTFS partitions, while usable in Linux, can act funny, especially if you’re dual-booting between Win & Linux (Windows 10 for example doesn’t shut down properly and can lock NTFS partitions making them unusable at all in Linux - another thing I learnt the hard way).


Thanks for the reply - good advise.

Windows not shutting down correctly can be mitigated somewhat by turning off Fast startup from the control panel items > Power options > System Settings and then Define power buttons and turn on password protection. Right at the bottom untick the 1st option for sure. The rest is up to your use case.


Thanks for the words @Sar - sounds a lot like the issues I’m facing.
Will go ext4 on the game-disk.
Thanks mate :slight_smile:

1 Like

Yeah, Microsoft’s fast shut down method had me thinking at one point I’d broken my linux installation, because I just couldn’t get into my NTFS drives after rebooting from Win10 into linux.

Then I found out about the fast shut down method they use (actually a hibernation variant), which prevents changes to the drive until Win10 is booted again lest something change and it affects how the drive is initialised on reboot.

Turning off fast shut down as you say Zeb solved that particular issue.

Not that I needed the solution for very long, because a few weeks later I deleted my Win10 installation completely and have been flying solo with Manjaro ever since.

No worries, fingers crossed it solves the issue for you, because it had me stymied for MONTHS, even across distros (Ubuntu Budgie, PopOS and finally Manjaro), until I had the light bulb moment and tested it with one game and lo and behold, the light at the end of the tunnel wasn’t an oncoming train named WINDOWS 10 USB STICK.

:joy: :relieved: :fist:

I always kept my Windows Steam directory on a separate drive which I still use in Linux. I never did have issues this way, but I have not removed Windows so it is not just a replication of my old setup but within Linux.

One thing I have always found useful for Steam issues in the past (and for other applications too) is to launch from the terminal - you often get very useful and relevant error information which is hidden by the GUI alone - saves digging through logs on many an occasion.