Running a Windows 11 Pro VM on a 12 year old laptop (i5-2520M; 8GB)

On Wednesday my Ryzen 3 2200G started to crash frequently and I have the feeling that it will take time to get it repaired. So I had to rely on my backup a 12 years old HP Elitebook 8460p. The comparison of both CPUs.

  • 2019: Ryzen 3 2200G (4C4T; 3.7GHz OC); 16GB DDR4; 512GB nvme SSD (3400/2300MB/s); 2TB HDD (192 MB/s) cached by a 128GB sata-SSD.
  • 2011: I5-2520M (2C4T; 2.5/3.2GHz); 8GB DDR3; 2TB HDD (120 MB/s).

I run Ubuntu 22.04 LTS with OpenZFS on both systems and every Saturday I backup all data and VMs from my desktop to my laptop using “send | ssh receive” from OpenZFS. After the crash I lost the upgrade of a VM from Fedora 37 to 38 on Tuesday and I lost some entries in my bookkeeping spreadsheet, but I added them manually again. The VMs (Communication and Banking) that took care of my daily work are now running on my laptop.
My current setup looks like:

As you can see, I still use the monitor; keyboard and mouse of the desktop. On the 1080p screen you see Firefox with the news and on the laptop screen you see my Xubuntu VM used for all external communication. Following are the 2 screenshots from the 1080p screen and 768p screen of the laptop.

The Host OS with Lollypop music player and some of my music (LPs; CDs and Singles):

The Xubuntu VM for communication:

I’m back at work and the whole operation took 2 hours, where I needed 1 hour to sort out how to manage 2 screens.

The current set up is workable, but slower. The CPU has less than half the speed of the 2nd slowest Ryzen. I miss my fast nvme-SSD and the laptop HDD is slower than my desktop HDD. Due to lack of memory I can run only 2 things at the same time, e.g Firefox and the Xubuntu VM. Once the system is stabilized it runs reasonably well, because for disk IO it runs largely of a 1.5GB memory cache (lz4 compressed).

The repair of my desktop took more time than expected, so last night I did run the upgrade of my main VMs and that included Windows 11 Pro.

I made a small error by allowing IOBit to start my app software updater, as a consequence its started the update of Firefox, Edge did start the update of Microsoft Edge and Windows did start the update of Windows. So more than 2 hours later all those update were finished, while running CPU and HDD at full speed most of the time :slight_smile: See also the screenshot. As you can see all memory has been used, main memory and SWAP are full, while the ZFS memory cache has been reduced from 1500 to 500 MB :slight_smile:

After the updates completed, the system rebooted faster than expected in 1 min 30 sec.

1 Like

Setup Pi-Hole if you haven’t already and cut down on the network use of Windows if you are into that idea. Turn off Windows smartscreen, and, because it is in a VM, and virtuaobox by default uses the host for system clock of the guest, disable network time update on Windows.

Beleive it or not, I run Windows 10 just fine with only two gigs of ram, because I wanted to test that, works great, even with a tiny 256mb Debian VM for pi-hole, but forgot to add it back in, so I run it like this now since my stick of memory is elsewhere

How much memory is used by Xubuntu, and how much by Windows 11?

Xubuntu uses 1.29GB and many programs are running for Evolution (email); Whatsie (WhatsApp); Transmission; HP stuff. Windows is using 79% of the assigned 4GB, say 3.16GB. The remaining memory is ZFS cache 0,6GB, page cache 0.4GB and Host OS (Ubuntu 22.04) and its Virtualbox overhead.

My memory problem is solved now, I’m back on my 16GB desktop.

Have you tried Barrier?

No, it was only a temporary 1 week solution, while I sorted out the HW problems with my desktop. I used two screens for fun.