Rsync permissions issue

I have an ubuntu server 22.04.3 running on a raspberry pi which I am using for jellyfin server. I have an external usb drive attached to it. If I ty to sync files across with -avz I get errors but with -rvz it works fine. I understand using -a is considered best practice. I did try generic duck duck going it and it seems to be something with permissions but I couldn’t quite follow what was being said. If someone understands it could they ELI5 what I have to do :rofl:

Blockquote
rsync -avz --progress ~/Downloads/test_folder/ user@192.168.1.88:/mnt/BlackBox/TV/test_folder/
sending incremental file list
rsync: [generator] chgrp “/mnt/BlackBox/TV/test_folder/.” failed: Operation not permitted (1)
./
test file.txt
2 100% 0.00kB/s 0:00:00 (xfr#1, to-chk=0/2)
rsync: [receiver] mkstemp “/mnt/BlackBox/TV/test_folder/.test file.txt.EV1Lcr” failed: Operation not permitted (1)
sent 143 bytes received 38 bytes 120.67 bytes/sec
total size is 2 speedup is 0.01
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1338) [sender=3.2.7]

The ‘chgrp’ portion pulls this up in a search: backup - Rsync operation not permitted - Unix & Linux Stack Exchange

Are you syncing from a Linux machine to the external drive? If so, what file format is on that external drive? Is it new? You might be able to reformat it to Fat32: How to Format USB Drives in Linux {3 Methods Explained}

it’s ntfs, I’m rsyncing from a tuxedo os (ubuntu base) laptop. I used to have the external usb drive connected to an ubuntu mate desktop box and could rsync to it with -avz no problem. So not sure what has changed. I did look at that article and tried a couple of the suggestions but to no avail, but I didn’t really understand what I was doing :smiley: I might research into permissions and see what I can find.

Solved, I think! I had incorrect fstab settings for mounting the drive I found the answer on ask ubuntu

https://askubuntu.com/questions/113733/how-to-mount-a-ntfs-partition-in-etc-fstab

I used this example from the top answer:

UUID=EEA2B69CA2B668AB        /WIN_C     ntfs-3g   defaults,nls=utf8,umask=000,dmask=027,fmask=137,uid=1000,gid=1000,windows_names 0 0

replacing the UUID = value with the UUID value of my drive, and /WIN_C with the mount point for my drive (/mnt/BlackBox)

Nice job!

Which pi are you using for Jellyfin server, what file formats do you have, and how many simultaneous streams? My old desktop ‘server’ is about full and I’m thinking about moving to another pi I have when I upgrade the storage.

I’m using a PI4, I’ve had two on it, it’s just me and my partner really. Plus I never have files over 1080p, in mix of formats, even though we have a 4k TV, saves disk space and I’m not sure I am enough of an audio visual aficionado to notice! I believe you can get hardware encoding done on it too to boost performance, but I haven’t quite figured out how to do it yet!

What formats? I think all mine are mp4 and mkv, and same thing, nothing over 1080p.