Problems installing HP LaserJet 1018 printer

As long time distro hopper, have rarely encountered issues installing this old printer.
But as of late, it has become practically impossible.
Just the other day, this suggestion from LinuxMint forum worked:
sudo apt-get update
sudo apt-get remove hplip cups-filters cups hplip-data system-config-printer-udev
sudo rm -v -rf /usr/share/hplip
sudo apt-get install printer-driver-foo2zjs printer-driver-foo2zjs-common
sudo apt-get install tix groff dc cups cups-filters
sudo getweb 1018
Disconnect the USB cable of the printer, count to five and reconnect it.
Launch the application Printers again from the menu and add your printer; you may have to click on the “refresh” button (the round arrow) first. Then print a test page.

But before, i successfully did this on Mint Cinnamon, i had tried a new Fedora based Gnome version (don’t like Gnome) called Nobara lauded by TechHut:

Think the HP LaserJet 1018 model was not on the list.

So, based on the tip from Mint forum, can similar protocol be used on this Fedora based distro?

1 Like

Hmmmm, Maybe add the RPM Fusion Repo and look in there for the HP printer driver ?

Saw your post… was away for a few days.

Sometimes, do see printer and its driver, but it just won’t install!
Get an error message now.
This never happened before (many years) until the past week or so.

(Enabling the RPM Fusion repositories :: Fedora Docs)

AUR? that’s Arch isn’t it?

If so, no, i didn’t and won’t go to anything based on Arch.

This solution looks promising, although the thread is a couple years old and the discussion meanders a bit.

@BluishHumility - did try downloading that today via MX XFCE - a no go.

Always get error message about corrupt checksum…

And, following up on @Arch-Penguin - did exceptionally go through download/install of Garuda.
Still can’t install the plugin via the HPLIP toolbox.

Maybe tomorrow, i’ll look into your tip.

So far, Mint XFCE and Cinnamon are the only ones that work.

If i have such a hassle with a printer, don’t know how i can ever encourage someone to adopt Linux.

1 Like

I had posted that as a solution that could work for your Fedora-based distro. Are you using MX Linux now? Or Garuda, or what?! :face_with_spiral_eyes:

MX Linux is Debian, so the Linux Mint solution should work fine.

If you are using Garuda…wait a second…

Oops, Garuda is based on Arch so be careful. :shushing_face:

Garuda should be a cinch to get your printer working since all the drivers you need can be found in the default repositories–hplip is in extra, hplip-plugin and foo2zjs-nightly are in the Chaotic AUR.

  extra/hplip 1:3.22.6-1 [21.13MiB 34.15MiB]
    Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet
  chaotic-aur/hplip-plugin 3.22.6-1 [1.46MiB 4.38MiB]
    Binary plugin for HPs hplip printer driver library
  chaotic-aur/foo2zjs-nightly 20201127-1.1 [10.70MiB 23.74MiB]
    foo2zjs Printer Drivers (automatically updated). Includes also foo2hp, foo2hbpl, foo2oak,
    foo2xqx, foo2qpdl, foo2slx, foo2hiperc and foo2lava drivers.

You can install them with Paru or Pacman, up to you. First bring the system fully up to date:


Then install your packages:

sudo pacman -S hplip hplip-plugin foo2zjs-nightly

That should be all you need for your printer to work. You might not even need hplip-plugin, I’m honestly not sure.

:thinking: I’m not sure why you are so quick to blame all of Linux for your difficulty getting your printer working, instead of…well, your printer. Regardless, if you don’t feel comfortable encouraging people to adopt Linux…:man_shrugging: then don’t! :slightly_smiling_face:

1 Like

Don’t want to blame Linux.
It’s just that, up until only about a week ago, it was practically a cynch to install the driver for almost any distros.
Now, all i get is some error message about checksum error.
Sorry for the confusion! :pleading_face: :flushed:
Maybe now that @Arch-Penguin has posted the link to RPM Fusion repos, i’ll give Fedora another try.

1 Like

FYI if you were using Nobara Project just know that the RPMFusion repositories are enabled by default on that distribution.


Just finished installing Nobara “official” with all the updates (almost 45 min. in all)!
Out of the box, it recognized the printer, but going over to HP toolbox, and try to install plugin:
“file does not match its checksum. File may have been corrupted or altered.”

Also tried downloading via terminal “hp-plugin -i”:
warning: nobaralinux distro is not found in AUTH_TYPES
error: Plugin download failed with error code = 8

error: file does not match its checksum. File may have been corrupted or altered

-(forget how huge the iso was, almost 5G!).