Prevent skype from starting automatically

My non Linux loving friends and I are meeting from time to time via Skype.

I was pleasantly surprised how easy it was to install Skype for Linux via snap, and overall it works well. I am not aware of any features my Windows running friends have that I don’t have.

However I have one annoyance with it. Whenever I login to my account Skype is launching automatically. I found no obvious way to disable this. I would like to start it up only when I plan to talk with my friends.

The instruction I found online about this assumes that I am logged into my Skype account, but I don’t want to do it, and I didn’t need to create an account just to have a chat with my friends.

Anybody have a suggestion how to block Skype from startup automatically?

I am not looking for a suggestion of any other virtual meeting solution. We, as a group already tested several of them, and Skype is working just fine for us.

Giving blind advice here but this might be a way to try…

  • Search for any configuration dotfiles Skype created
  • Check inside them if there’s any magic variables that turn off autostart

If not…

  • Create a throw-away VM
  • Install Skype and log in with a throw-away account
  • Turn off autostart
  • Search for any configuration dotfiles Skype created
  • Check inside them if there’s any magic variables that turn off autostart that weren’t there before.
  • Remove any entry pertaining to the throw away account and move the dotfile to the host.

What is your Desktop Environment?

I have Skype installed and use it very rarely for that occasion when I want to talk to family members.
You have to go to the Skype options or preferences and I know you can turn off auto start.
Let me know if you can find that setting. If not I will open Skype here on my machine and check for it precisely.

PS: The toggle option should be in Skype → Settings → on the left sidebar General → Then look at the right side.

It is a setting within Skype itself.

@Ethanol, I am running Kubuntu 20.04 (KDE 5.18.5)
@vinylninja, @eastcoastweb - I suspected as much, but since I am not logged-in my Settings menu is grayed out.

I could replicate this with Lubuntu. I fixed the issue just by turning it off in startup applications. It was called “snap user application autostart helper”.

In KDE Plasma you’ll need to open the settings – > Startup and Shutdown
Then check the Autostart, or background services for the snap process

1 Like

I had no idea you could actually use Skype without an account. I learned something new.
So yes, you have to do it manually.

You need to sign in to Skype first to get to the option to disable it on startup…

Looking at mine… log in to skype, go to Tools → Settings.

Click on General and you should see the “Automatically start Skype” option: