Phones Choices


The branding is different (although No Agenda Show is pretty loose with their branding) and I can’t find any mention of a phone on No Agenda Show’s website or store with a quick search.

It also seems to be run by “a dude”?

“Contact Me
If you would still like a professional (or at least a dude who’s done this a few times) to help set you up or have any questions or comments, please contact me here:”

Do you have a confirmation link it’s by No Agenda Show?

Thanks @Eltuxo, great link either way.

1 Like

Well, it’s a sattelite (by lack of a better word) of the NoAgendaShow. The people behind this shop donate an amount of the proceedings back to the show.
The same with the noagenda shop. (hoodies, t-shirts, etc…)
Nothing official, but that’s the point. There is no demonitization / deplatforming possible, because everything is run independent from each other. The only thing they share is the name and the ideas behind the concept.
The show has an OTG segment from time to time, and that’s how this “dude” (also known as a producer) set up shop and started to root phones with Graphene OS.
He started out doing this for the NoAgenda community, but has broadened his scope, due to the succes of this concept. (Again, only in the U.S. It’s too expensive to get them shipped to the EU (customs are going to have fun with this) and i’ve bricked a phone or two when trying to root them.

I’m really glad to see people doing this it’s such a good idea. Most people aren’t up to flashing their own phones and there’s definitely risk especially when it’s a model you haven’t flashed before.

1 Like

Has it arrived yet?

Not yet. I sent them a mail asking for an update earlier on this week and the reply was as follows:

quote: “Good afternoon,
I expect the delivery this month. Unfortunately, I can not say more precisely at the moment.
Kind regards

So that’s that. I’m eagerly awaiting it’s arrival.
My guess is that somewhere next week, i’ll get a message telling me that it’s on it’s way. (or at least, that’s what i hope).

Update: i got a message that it’s being shipped somewhere this week. Tomorrow or Wednesday. As soon as the DHL tracking number is available, they’ll send it. Can’t wait… :stuck_out_tongue:

1 Like

I am using microG Lineage.

Anytime I get a new phone, I check Lineage OS’ supported list to ensure it’s compatible. So far, the longest-lasting (supported) has been a Oneplus model.

I still have my older phone which was dropped when Lineage 14 was EOL, it recently got updated for Lineage 17 again so I upgraded it as soon as I saw. I don’t use that one as a daily driver anymore, but keep it around for tinkering/backup.

Would love to get a more "Linux"y phone, but I use a few apps for banking and work so I will always have to keep an Android around in some manner.

My first Lineage phone was a dirt cheap Motorola. I went through the supported list to find the most inexpensive model I could obtain locally, as I expected to brick it in my first try. :slight_smile: (I did not) Ended up using that phone for years!

It’s being delivered coming Monday. I’m anxious to find out how it will work.

1 Like

You may have to wait for it, but the Librem 5 is amazing. I have one ordered, but a friend got his and I was blown away.

Well, i received my phone yesterday. Been playing around with it for some time now.
The first drawback i encountered is that it doesn’t want to pair with my bt headset. (bose sports). It seems it’s a known bug. No problem, it’s got a 3,5mm jack.
But besides that, it’s exactly what i thought it would be.
It’ll take some getting used to and learning new things, especially since i haven’t used a "smart"phone for years, but i’m happy with this.
I’m looking forward to further development of this phone/os.

1 Like

It seem rare anymore to have a 3.5mm jack. Gals that is an option while the bug is being worked out. So when you have had it for a week, I’m looking forward to an update on how it is going.

Not exactly a week, but here’s an update.
It works! :grin:
Of course, it needs further development, but i’ve said that before.

Sending/receiving calls, texting, the usual stuff works just fine.
Surfing on the web via the built in browser (Morph) goes smooth.
Connecting to wifi / carrier network: the phone sometimes forget that it has connected to a wifi network already, and will ask if it can connect or forget the wifi network, the moment it leaves / enters its reach. But that’s a slight annoyance.
The Open Store has a lot of unofficial apps for popular apps you’ll find on android.
Ubuntu touch makes it possible to have android apps via Anbox. (Android in a Box).
This weekend i’ll check out the signal app (Axolotl beta).
I’ve seen that they have an app for Protonmail too, but i don’t know if i’m going to use that. (paranoid side of me).
The 4 sides of the phone, and this is really useful, all have their function.
Swiping from left to right, gives you the panel. Swiping from top to bottom gives you access to various settings. (messages, wifi, location, etc…)
Swiping from right to left: cycle through apps that are currently in use and can be closed with swiping from bottom to top. (extremely handy, imho)
A full battery has around 2 days of use in it. But i listen/download podcasts a lot, so it’s different for everybody.
That’s all i can think about for now, i’ll have more to say within a week or so. (After installing and using several apps for communication, mail (if any), etc…))
I hope this helps.


I recently switched over to using a Pixel 4a (4G) running Graphene OS and have to say all in all I’m happy with it. F-Droid has a good selection of apps. Additionally there is an Aurora store that allows access to most apps in the Google Play store. Aurora also provides info on the trackers the apps in its store has. You don’t need to log into a Google account to use the Aurora store either.


Being Google free, I would venture F Droid has most things you would need (except games). Let us know how you get on with it, I know it’s a big change!

I did have several paid apps that can’t be used on the new phone. Apps which were used a lot. I miss Pocketcast mostly. It was replaced with AntennaPod. Threema was installed on a tablet which is more convenient anyway since it’s connected to a physical keyboard and to my desktop through a web app. There really isn’t a good navigation app though. But I’ll pick up a Garmin at some point. I haven’t been doing much traveling lately any way.

I agree, Pinephone is working much better than it was when I first received my UBPorts Edition. I currently use it with Mobian but got an itch to put Manjaro on it. Still, I use my Venerable Samsung S7 with as many apps from F-Droid as I can. Now I am contemplating getting Sony Experia XA2 from eBay and instaling Sailfish OS on it (so I can have just another device to play with). Have any of you had any experience, good or bad with Sailfish OS? I believe the Russian government is using it, so it must be good, lol

I think vinylninja had it best:

How’s your Mobian experience going @methanoid?

I have a testing thread to get back to but I ran into something i’d call the pinephone reviewer’s dilemma several months ago.

On first install things would work great… but if I tried to use it as a primary phone i’d get freeze ups, not ringing with the screen off, not waking up which forced a reset, missed SMS/calls, misc quirky behavior and then there was the questions… did I mess up? is it the hardware? is it the software? is it a problem with the spin or the original? is it a one-off bad version? have I used it long enough for a credible opinion? do the 2 new versions that dropped during my 1 week test fix the issues? should alpha/beta software even be the subject of an in-depth review? Yeah… it was rough :stuck_out_tongue:

Only tried SailFish for an hour… it felt way too locked down and reminded me of a Fisher-Price play set. Would probably be great for calls/sms though.

1 Like

Navigation app is hard to find, I agree. Let me know what you come up with. I’ve tried OSM, but downloading the map and trying to navigate off it is tough.

I’ve used OSM a little bit and found it OK, but my big problem is that it doesn’t have any addresses for my area so trying to search for residential or commercial address is impossible. I have to import the GIS data manually or something, I don’t know. I could navigate with GPS coordinates or get as close to an address as the street it is on.

When you say that you have tried OSM, are you referring to the OSMAnd app?