openSUSE Yast DARK color scheme/theme

One of a handful of pain points I have with openSUSE is that Yast does not follow the users system theme. I use a dark theme but Yast opens up with a blinding white window regardless of the theme I’ve chosen.

Now that I’m posting this I see a few solutions that probably would have worked but they are not presented with much confidence or are kinda old. Anyways, I’ll put this up here for future reference for myself if anything

Yast2 runs as a root process and derives it’s settings from the root user. We have to change the color theme settings for the root account.

This solution is for KDE Plasma only, you’ll have to interpret slightly different steps for different DEs

CLI Method

Step one

open a terminal and type:
to switch to the root user. Enter the root password when prompted

Step two

From the terminal, now logged in as the root user, run the KDE Plasma color themes module like so:
kcmshell5 kcm_colors

Step three

Choose your color theme of choice

Step four


GUI Method

  • Log out of your user account with the GUI method
  • Log in as the Root user
    • type “root” into the user input if this isn’t available in a list of users
  • Change your theme settings the usual GUI way.
  • Logout, reboot.