OpenSUSE 15.3 / KDE Breaking (Bad!)

Good evening DL Community,

I’m back (again lol) with some new issues that I can’t seem to understand and looking for some input.

  • Distro/Version: OpenSUSE 15.3
  • Kernel: 5.3.18-52
  • Started: It’s been going on with KDE breaks for over three weeks but worsening each week
  • Change the likely caused issues: Unsure; been pretty stable and not playing around too much with configs.
  • Steps taken to solve issue: I have attempted to try the different KDE/Plasma options for the DE such as vanilla Plasma, Plasma (Wayland), and Plasma (Full Wayland) each had varying worse issues lol
  • Set Up (please keep in mind - this is just a lab box): CPU: AMD FX-4300 (4) @ 3.800GHz / GPU: NVIDIA GeForce GTX 1060 6GB / dual monitors - Acers

What’s the problem?:

My system started to act funny first with KDE Plasma with the Night Mode. I had the issue start on both my laptop and lab box. The night mode just would stop sticking to “all the time” on style. While on the laptop it reverted to a time frame, the lab is REALLY going down hill…

Turning on the box today, the monitors reversed their position (1 reversed with 2). I fixed this and changed them back - and then it went from “oh, you reversed?” to - “Why is the left screen extending, literally, into the right screen now… and why is the right screen shaking?” Also, the screen resolution was set correctly (based on system display settings) but WOW was everything SUPER big. lol

I could not solve this complication so I moved forward with doing a restart in case that would help. Returning, it did not change anything and the symptoms lasted. So, I downloaded XFCE for an alternative DE to reference if it was system specific or if this was possible just a DE/KDE issue.

Positive side, XFCE works flawlessly. Sad panda side… trying out the different Plasma options after logging out each time - the experiences were terrible. While vanilla Plasma had the screen issues, Wayland options were either entirely broken or they would open, show a brief background, go entirely black, and then return with a floating terminal window that I keep open just in case needed (thankfully!).

So, with all that shared, I wanted to reach out and ask if others have come across a weird example like this or similar? What did you do to fix the situation?

The next step I am attempting is:

sudo zypper remove -t pattern kde kde_plasma
sudo zypper install -t pattern kde kde_plasma

I’m not sure if this will help but so far, I could not find any other alternative ideas. I’m not sure… maybe I broke it and there could have been a cache cleaning option?

So, update…

Yeah, the next attempted idea of removing KDE and reinstalling was a bust… :frowning:

I’ll keep playing around with it though since… I mean, it’s fun to tinker :slight_smile:

On the plus side 15.3 is still Beta, so it should get better and you should report this to the OS team so this can get worked out before official release.

1 Like

Exactly, and that is what I was thinking to do, too; reaching out to the OpenSUSE community to ask if there is a way I could better communicate this issue to understand if it is a DE issue or user created issue.

I’m not entirely sure what could have caused this massive bust.

However, XFCE, never used before and so far - not too bad. But, I am not really understanding their properties on the display bars… I’d like it to be a little different. Positive side, I’m outside of my regular KDE experience and trying out new things :slight_smile:

You should try creating a new user account. Login with that account on KDE and make your adjustments and see if it breaks there as well. You might find that there’s something wrong with the user settings and not KDE itself.

1 Like

Hey there Ethanol,

Thanks for the idea! That should have been something I attempted, you’re totally right.

I wanted to reach back on this to share that I am pretty confident this is NOT a specific DE related issue, any more. I just popped on my lab box this evening into XFCE and it is gone bad in its own way. The GUI interface options are not responding, the GUI typing options are not responding, and terminal is not allowing any key inputs.

Oddly enough, I write this from the lab box so it is not related to browser only the system itself.

I have reached out to OpenSUSE community for input and guidance, too :slight_smile: I’m hopeful and looking forward to the opportunity of learning from this - so much! :slight_smile:

So, it’s too early to tell, since XFCE was working perfectly yesterday and then did not today, but I just did a simple useradd with user test on the system, popped in and - no issues.

So, I definitely might be related to the main user account… I’m not sure what I did and might be a complete break issue.

Hey Ethanol,

So, I couldn’t let this go, so I have been tinkering/learning more on this for the last week.

I won’t bog you down with extreme amounts of detail, so I will shorten this and share where I am at.

I believe the source of my issue is related to (SURPRISE): a combination of UE & NVIDIA.

To explain that better, during the Yast installation process, there is a pop-up box that I likely glossed over during the 15.3 installation (much like signing away our lives with a EULA) which warns: using Mesa-dri-nouveau has known issues with DE’s where they break many factors of those DE’s; most notable - KDE.

Information for package Mesa-dri-nouveau:

Repository : Main Repository
Name : Mesa-dri-nouveau
Version : 19.3.4-lp152.27.1
Arch : x86_64
Vendor : openSUSE
Installed Size : 31.0 MiB
Installed : No
Status : not installed
Source package : Mesa-drivers-19.3.4-lp152.27.1.src
Summary : Mesa DRI plug-in for 3D acceleration via Nouveau
Description :
This package contains, which is necessary for
Nouveau’s 3D acceleration to work. It is packaged separately
since it is still experimental.

Next, I believe that I must have not truly installed the drivers properly the first time. So, following the OpenSUSE Wiki’s NVIDIA drivers directions, I started there rather than taking other suggestive alternatives.

That source is found here: SDB:NVIDIA drivers - openSUSE Wiki

Presently, I have downgraded to 15.2 so to run an experiment with the graphical experience and I am using XFCE. After not installing the mesa driver and properly installing the NVIDIA system drivers, the experience has been very positive.

I’m planning to set up a KVM/VM with OpenSUSE 15.3/KDE Plasma and follow the steps I have taken above with my present set up to see if that experience solves my beginning stated issue.

I hope this makes sense; I figured I would follow up to share how much further I have gotten and the positive gains made. Plus, again, so-so much fun with the learning experience.

I hope you are well :slight_smile:

1 Like

Ah, of course NVIDIA! Say no more!

The nouveau drivers can only do so much unfortunately. Thanks for the update!

1 Like

Wish I could help but I love hearing it develop. That statement’s music to my ears, well done on the progress.

1 Like

ROFL! Right… totally my fault but I didn’t want to buy new hardware and create more e-waste, so I re-used this old Video Card into this lab. But, I forgot - Nvidia… LOL

Absolutely! I had so much fun learning it all :slight_smile:

Thanks for the support :slight_smile: