No LAN after install of PopOS 21.04 (SOLVED)


I have a Desktop-PC from Tuxedo Computer. I made a “hwinfo” so far:

The thing is: I always had PopOS 20.04 LTS (or other LTS-Versions of Ubuntu installed, even Manjaro or so…).

The LAN-Adapter always worked.

Now I did a fresh install of Pop OS 21.04 and the internal LAN just does not work. At the moment, I am using a USB-to-LAN adapter on that same PC, for beeing able to write here.

I dont know exactly how to debug this. I can only imagine, that it is a kernel thing not playing with my mainboard. :frowning:

This is the output of my “ifconfig”:

As you can see, I gave the IP-addresses manually: 10 is the internal, 15 is the external (USB-to-LAN) adapter.

Even with DHCP the internal did not work.

Could someone perhaps assist me how to solve this? Also via Telegram directly. (@pragomer)

Thank you already and kind regards


Have you tried running ubuntu-drivers list?

This is somewhat similar to my problem, except it only happens when I put it to sleep.

Might be a good idea to ask in the Pop!_OS subreddit

Hi, that command shows me this here :thinking:

But as I can see HERE, the network adapter is recognized correctly :thinking:

Combining some info here:

# Onboard adapter that doesn't work
enp6s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
inet  netmask  broadcast
net driver: name = r8169, path = /bus/pci/drivers/r8169
E: ID_VENDOR_FROM_DATABASE=Realtek Semiconductor Co., Ltd.
E: ID_MODEL_FROM_DATABASE=RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (Onboard Ethernet)

# USB that does work
enxa0cec8041c6a: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
inet  netmask  broadcast
net driver: name = ax88179_178a, path = /bus/usb/drivers/ax88179_178a
E: ID_MODEL_FROM_DATABASE=AX88179 Gigabit Ethernet

Diagnosing this using a static IP adds more plausible issues it could be, i’d strongly recommend going back to DHCP for diagnosis.

As a simple thing to start with, try pinging your router:

# Get router IP if you don have it:
ip r | grep default

What’s interesting is the id model is: RTL8111/8168/8411
But the driver it’s using is: r8169

The r8168-dkms package is bingo on all the model#'s in your device:

"r8168 is the Linux device driver released by RealTek for their network
controllers with PCI-Express interface:

  • 10/100/1000M Gigabit Ethernet: RTL8111B, RTL8111C, RTL8111D, RTL8111E,
    RTL8111F, RTL8111G(S), RTL8111H(S), RTL8118(A)(S), RTL8119i, RTL8111L,
    RTL8168B, RTL8168E, RTL8168H, RTL8111DP, RTL8111EP, RTL8111FP, RTL8411,

Try installing it and do a reset:

sudo apt install r8168-dkms

Confirm it’s in use after reset:

hwinfo | grep "net driver: name ="

It should not say: net driver: name = r8169, path = /bus/pci/drivers/r8169

If that doesn’t work, please give me the result from the following command so I can dig a bit more:

sudo lspci | grep "Ethernet controller"

A little more info…

"r8169 is an in-tree kernel driver that supports a few Ethernet adapters including R8168.

r8168 module built from source provided by Realtek.

In some cases new adapters don’t get good support by Linux kernel immediately after they are released. In that case using r8168 makes sense as a temporary solution till Linux driver is fixed."

networking - r8168/r8169 - which one should I use? - Ask Ubuntu

The driver you’re using (r8169) appears to be the Kernel driver for your card which may not sufficiently support your device. In your case it could be the Kernel driver doesn’t play well with your OS upgrade. r8168-dkms is Realtek’s driver.

Hi friends,

thank you so much for putting your time in helping me. I tried a lot to solve this, but the issue was more hardware wise, I think. Because:

I tested out different things, and also rebooted a lot. But what I never did was: really to shut down the PC and unplug the AC. After I did that, the adapter worked back fine again.

I think I have to “book” it under “strange computer issues”.

But thank you, in any case, very very much.

Kind regards!

1 Like

Glad it worked!

Thank you for sharing what did it.