Microsoft Hates Dual Booting?

So I recently installed Fedora on a shared computer (my sister and I use it). I bought a low memory sata ssd (Kingston 240GB) just for this. I installed Fedora, including the bootloader, on the new ssd. I didn’t touch any of the other disks (hybrid, ssd + hdd), which are partitioned to use Windows for my sister. This means the Windows bootloader is installed on one ssd while grub is installed on the other. This hasn’t caused any problems so far other than Windows asking to repair on boot every time. After repairing, Windows runs as usual. I’m afraid it could potentially cause problems in the future, considering how Windows hates dual booting. I didn’t expect it to react when grub was installed on a different drive.

Has this happened to anyone else? Any advice in this situation?

Which drive is set to boot first in the UEFI/bios settings? Fedora or Windows?

I’m using UEFI and Fedora is set to boot first. Windows Boot Manager shows up as an option in grub.

That’s how I have a triple boot laptop setup except the system names were modified using grub customizer. I changed the Windows Book Manager to just read Windows 10. I haven’t had any issues with it involving Windows though. So long as the systems are on separate drives Windows tends to get along fairly well or it has for me. The only issue I had is that I used the grub boot loader from the Endeavour partion but had the Feren partion boot first in UEFI settings. So when grub updated in Feren it would boot from the grub boot loader on the Feren partition. The fix was to go back into UEFI and set the Endeavour partition as the initial boot drive.

I doubt you will have a problem so long as Windows and Fedora are on separate drives. Have you themed the grub boot loader? Chris Titus has a good tutorial on how to do that along with a script and about five themes.

Thanks for the detailed reply. I feel a bit reassured. I’ll try setting Windows as the priority and see what happens. Hopefully it’ll fix the repair problem.

I haven’t tried to theme grub. Never thought of it actually. I’ll check out his videos anyway.

1 Like

If that fails and you’re on a desktop instead of setting up the system as a dual boot see about getting an icy dock and swap out the system drives each time you change users. That is how my main desktop is currently setup.

1 Like

Thanks for the suggestion. This is also a temporary setup anyway. We’re building a new PC and I’ll be using this old one.

Update: Changing the boot priority worked. Windows no longer complains.