Lutris not opening

im trying to install lutris and it not drving me nuts. it installed but not opening

Run it from the terminal and see what the output is. What distro are you using?


well i ditch it for Retroarch. retroarch is running without a hitch!

I installed Pop OS on a new laptop and I have the same issue. Apparently it’s related to a python version not installed on the OS. I’ll have to dig out a little because, as it happens a lot of times, people pointing to the solution say “just installed python-lxml and now it works”. As a relative newbie that doesn’t tell me how to do that :man_shrugging:

On Linux Mint, I can simply search for this package in the terminal with sudo apt-cache search python-lxml
I think on Pop, apt is a little different, you might get away with sudo apt search python-lxml

The result lists the package python-lxml that’s the whole package. Just sudo apt install python-lxml in the terminal and it will install. Restart Lutris and see if that helped, if no, try logging out then back in and start Lutris.

After posting I thought I could give sudo apt install a try (I didn’t know about apt search though). Installation doesn’t work, terminal says there’s no version available but it exist in the database. Package is missing or obsolete. I removed Lutris for now as I only use it for two games. One is an AppImage so it’s only convenient and the other I’ll try via Wine directly.

Interesting. My system finds and installs it just fine. I’m on LInux Mint 20.1 which is based on Ubuntu 20.04. Pop should be on the same version too with the same package base . The other option is to use Pip, the python package installer. Install pip first sudo apt install python3-pip then run pip install lxml or possibly pip3 install lxml

I’m on Pop OS 20.10 (should have specified that from the start). It keeps getting interesting… Installing pip when flawless but installing python gives “Requirement already satisfied: lxml in /usr/lib/python3/dist-packages (4.5.2)” so I guess python is already there. I tired again Lutris and still goes missing after launching :man_shrugging:
Think I’ll wait for the developer to correct that…

This could also be the issue.

Funny enough, I just installed Lutris on a new machine and was having the same problem. Without any terminal output it’s hard to know what your problem is. However, based on my errors I found this thread on reddit and downloading the file linked there did solve the problem.

1 Like

Thanks for sticking with it and trying to help :grinning: The file in the reddit thread did solve the problem :+1:
For my info what kind of terminal output would you need ? Running the app via the terminal I suppose (don’t know how to do that) ?

From the terminal just type lutris and it will launch. Don’t close the terminal though, that will kill the process and close lutris.

For me it output a ton of gobbledy-gook about python but right at the end it said file not found: ~/blah/blah/blah and that got me on the right path to search for solutions.

I’m glad you got it sorted. I’m going to add an issue to the lutris GitHub. Downloading a file from some Reddit thread is not really great.

1 Like

I really thought it needed a command or something to run an app via the terminal, very neat function :blush:

I went to the Lutris discourse looking for a solution about a game installation hanging and there I saw multiple threads about Lutris not starting (why didn’t DuckDuckGo picked those when I searched :man_shrugging:). Apparently the file comes from a member of Lutris team and the problem will be addressed shortly via an update.

1 Like

As long as a program is in the $PATH for bash you can run it simply by typing its name. Unfortunately the names of programs are obfuscated quite often. For example, on Mint I have a program called “Text Editor” in my menu. To run it from the terminal I actually have to run xed. Or “Disk Usage Analyzer” is run by typing baobab.Mint comes with a “USB Image Writer” but it runs from the terminal with mintstick -m iso. It’s a matter of finding the program name by clicking on its “about” menu item, or running top or htop in the terminal, finding its process when it’s running and looking down the row at the actual file path.

But I digress.

I saw an update to Lutris just now. So I sudo apt purge lutris and completely removed the lutris folder from ~/.share/lutris. That should have removed any of the manual configuring I did previously. Then reinstalled lutris and it opens! So it appears the issue you and I were having is now solved.

1 Like

Does it not removed your installed game ? If so I might just leave it like that for now as I don’t wan’t to install all again 48h later :sweat_smile:

The only thing I had installed was a non-working Office 365 so I wasn’t worried. Lutris makes its own games directory for wine prefixes though doesn’t it? Those should remain if you uninstall lutris.

No update yet for me, I’ll backup the save file for the game I currently play and we’ll see :smile:

Oh, you are on Pop which ships lutris right in the Pop Shop. I am using the PPA for lutris so my version will be the most recent one as soon as it’s released