Linuxmint Nemo search IN Word Documents

Hi,
I just could “convert” another friend of mine to linux. I installed him Linuxmint. He is a language-oriented teacher who writes a lot of documents. His documents have the doc or docx format.

He asked me about not beeing able to search for a file in Linuxmint’s filemanager nemo “by content”. So, he searches for a termin that is part of his document. He tells me if this would not work (like it did for him in Windows 10), he wants to return to Windows. All apart from this works fine for him. He has ca. 1000 documents.

I tried this in Vbox and with Linuxmint 20, and he is right: Nemo does not search in doc-files. Neither does Catfish do this.

Am I missing something or is this not possible with nemo?

Edit: Nautilus doesnt work either in Linuxmint for this.

(I myself use Manjaro KDE)

Edit2: I tried and created a txt-file. I can find its content with catfish. But not the doc-files. So is it a problem with doc-format?

Edit3: Ok, and even Plasma’s Dolphin isnt able to search in doc-files content.

I do not use doc files so I have not exerienced this. You could try Drill for him to see if that will solve the issue?

I don’t know nemo but with catfish… searching file contents for any search software is very hardware/cpu intensive so it’s not on by default. To use it in catfish:

  1. Enter text you’re looking for within the files
  2. Click top-right cog icon
  3. Check “search file contents”

Correction: does not work with .odt / .doc contents.

2 Likes

Hi Folks,

yes, I was happy for beeing able to “switch” him to linux, as my intention is to get the whole school to linux LOL. So it would be a pitty if it would struggle with an issue like this.

Me I dont use doc either Michael… but ok its a school and so I have to find a way for doc-files.

I created a testfile in Vbox with Linuxmint:

And just discovered that Nautilus IS able to find it (and Nemo is not)

So… I think I can offer this as a solution.

Btw @Ulfnic
I also tried catfish:

But it does not find the term “findmy…”. Even with search in filecontent enabled. And my search parameters would not be *.odt or *.doc… but “findmytext”, right?

Kind regards to U2 :wink:

PS: I think the reason why I wrote nautilus would not work either in the 1st place was, perhaps it took the system a bit of time to index the files.

So, conclusion: nautilus works, nemo does not.

I think even in Gnome Shell (on the Gnome desktop) itself you can search by those patterns.

Edit: I tried Catfish on my Xfce desktop and it finds the content of documents.

HAH! messed that up :stuck_out_tongue: Made the correction. Technically you might be looking for “*.doc” within a file!

On a side note I found this script for searching inside ODTs but it’s terminal:

How to search for text inside many OpenDocument files | TechRepublic

Hi @ vinylninja,

I am (was) also a very long XFCE-User. Does catfish work for you even in doc-file-format’s content?
I discovered that catfish does not find content in doc-files, but perhaps I have to re-try it under an explicit XFCE-DE.

I’m on Debian using XFCE4 v4.14 and catfish v1.4.13-1. It won’t let me search within doc-files.

When I looked into it (as far as Open Office goes), it appears they’re a compressed format. I also didn’t see any plugin support for Catfish as an easy solution for compressed files.

I tried it and it seems not to be working. It still is spinning.
Besides I do not think it has anything to do with the desktop environment.

The next time you want to refer to me, reply to my original post or include my username exactly after the ‘@’ @pragomer like I did hear and I will not miss the post. :wink: