KDE Plasma / OpenSUSE 15.3 - Night Color Mode Broken

Hey there DLN Community,

I could really use your help on something that is just really beyond my ability to find a solution via SE work.

Right now, my Night Color mode in KDE for OpenSUSE 15.3 (beta) is broken. I’m not sure if this is specific to beta or just a KDE issue which is why I was hoping to reach out and ask for some advice. (I’m also planning to share this with KDE community and I have already started a discussion with OpenSUSE team but we haven’t found a solution yet).

Right now, whenever I go into display settings to change it back to Night Mode, the DE does not register that I am looking to use an active “always on” Night Mode. Even if I try and change the set custom time (which is where it is stuck at) the times won’t create any impact.

Last night, Night Mode was perfectly fine but I’ve started having issues starting a few days prior.

Things I have tried:

  • Reset defaults in display (apply won’t activate)
  • Play with the different Night Mode settings (nothing)
  • Shutdown and restart (nothing still)
  • Do a TON of searching around (haven’t had any luck :frowning: )

Any further advice and guidance would be greatly valued. Please don’t think that your advice won’t be accepted or will be considered not worthy of me trying out. I am very open to trying out multiple ideas and any idea might work.

Thank you all so much :slight_smile:

Most likely won’t solve the issue but worth a try:

Create a new user account called test, login to test and see if Night Color mode works correctly. Helps to see if it’s a dotfile conflict.

1 Like

Hey there Ulfnic,

Good idea! I went ahead and made a fake user, temp account. I logged into the account, with just regular user privileges.

I went into the account and moved forward with changing the system settings to Night Color mode. It changed but then leaving that display setting areas the Night Color mode reverted back even though it was set to active always and apply.

I went back in and preformed a turn off, apply, then active, and then apply again. It worked the 2nd time.

Confirming this, I moved back to my regular account and did a userdel on the temp account. Then, I checked Night Color mode for my regular user account and found it was on, active, and working but set to a time frame that I did not designate.

Going into Night Color display option, the blue light turned back on, and attempting to turn it off or turn it to “Always on” did not make any change. Leaving the setting and re-entering also did not have an impact, and blue light stayed on… :frowning:

I’m not sure if there is a command line issuing I could do to force this change to happen on demand… ONTO THE DUCK AGAIN! LOL :smiley:

Worse comes to worse, I could try another DE but I really did enjoy KDE.

Thanks for your advice and idea!!! :smiley: