KDE - Active Monitor (dual monitor), active window

Please provide as much information as possible to allow others to assist you. The more information you can provide the better.

  • Distribution & Version (ex: Ubuntu 18.04) Fedora 33
  • Kernel information (type in terminal: uname -A) 5.11.8-200.fc33.x86_64
  • When did the issue start happening? As soon as I started using KDE Plasma a month ago
  • Did anything change that caused it? (hardware change, upgrade) No
  • What steps do you take that cause the problem? Huh?

I have Fedora Gnome installation I have been using since Fedora 31 back in 2019. I am currently on Fedora 33. I have a dual monitor setup and have never had this issue until installing KDE Plasma. I installed KDE Plasma about a month ago. I decided to try out KDE after not using it for over 15 years. I have never really been a Gnome fan but it is something I have grown accustomed to and it has always worked for my workflow. I like what I have seen so far in KDE Plasma but if I can’t get this annoyance fixed I will be switching back to Gnome.
I notice that every time a new window opens it opens on my secondary monitor and not my primary monitor. This is a huge annoyance. I am currently on KDE Plasma 5.20.5.
Has anyone run into this issue? Does anyone know of a fix for this?
I completed some internet searches but have not found a solution yet.
Any assistance would be greatly appreciated.

In settings → windows you should be able to add custom rules. Make one applying to all windows and set it to use main screen at start.

Thanks for the reply.
So, there isn’t something I can disable or enable instead without having to create a custom rule?
Seems like this is a broken DE, if that is the case. Perhaps a bug that should be reported?

I don’t know. Perhaps there is a better way to do it, but because I don’t use multiple monitors, I’m not aware of it.

Thanks for your response.
I wish there was a solution.

Disclaimer: I dont use KDE, this is just what I dug up.

I paraphrased an answer, might help…

By ws-ilazki,

KDE applications store their own size and position information in their configuration files, and there’s been a long-lived problem with this and multi-display setups.

kwin makes it easy to work around program warts like that with window rules.

You can get to window rules in system settings, under “Window Management”, in the “Window Rules” section. You can set new rules there, or by right-clicking an application’s title bar and choosing one of the “Special [Window|Application] Settings” entries under “More Actions”. In the case of misbehaving window placement, the settings you most likely want, in the size&position tab:

  • Set “position” to “remember”
  • If size is being forgotten as well, set “size” to “remember”
  • Set “screen” to “remember” if it’s losing which display to appear on
  • Finally, and most importantly, set “Ignore requested geometry” to “force” and tick the “yes” radio button.

The last one is important because it tells kwin to disregard any request for window placement the application sends. Without that, it will still try to do what the application requests instead of using the other settings.


Thanks. It seems I remember seeing that thread in my research also. Unfortunately, as it may have been stated in that thread or one similar, it would be really painful and tedious to have to do this rule setup for every application.
You would think that KDE, like other DEs, would set a default that all windows open in the primary display that was set. It’s actually kind of weird that all windows automatically open on the non-primary display. Seems like this is a bug that really needs to be addressed.