Jitsi meet on Digital Ocean droplet

So I want to keep close with my family scattered all over the globe.
I settled on Jitsi using a $5 droplet on Digital Ocean with Ubuntu 20.04
I bought a domain from namecheap and opened an account with DO.
DO has a “One click” Jitsi install on marketplace tab. Easy for a computer newbie right? Not!!

Assume my new domain is example.com I create a subdomain of meet.example.com
I ping example.com and meet.example.com. Both are live on the network.
I name the droplet “meet.example.com
I create the droplet and SSH onto the root@xxx.xxx.xxx.xxx as directed
All goes well until I enter my email apply for the lets-encrypt SSLcertificate
then I get a warning http-01 error and jitsi doesn’t appear on my domain I’m think Idoing wrong or mis-configuring my domain.
Any help appreciated. or send me off to another appropriate forum.

1 Like

Some troubleshooting…


I’ve used Jitsi in its very basic form (via Firefox or Flatpak) as my go-to videoconferencing app for basic needs, throughout lockdown due to Covid and really like the idea of self-hosting it as an option though I know far too little currently to even try! I hope you get it working for you!

thanks. I muddled through the instructions for what they are worth -
on namecheap - I changed from their dns to a custom dns pointing to the digital ocean name servers.
added several “A” records pointing to jitsi-meet.my.domain
Finally got a Welcome to nginx server with the admonition that Cmore configuration is needed. GROAN
logged on to the root@xxx.xxx.xxx.xxx

edited /etc/jitsi/jicofo/sip-communicator.properties in nano text editor by adding the line

typed the command -
systemctl restart {prosody,jicofo,jitsi-videobridge2,nginx}
and logged off as root

i opened the URL inn FF. It complained that I was in great danger of covid and starting WW3 if I entered the site. Did it any way!! SUCCESS
DO has many 404 pages. One click - NOT

I got it running. I’m a noob. I There are some videos on YouTube that use Ubuntu 18.04 but they are not ONE click however, the DO marketplace jitsi isn’t either. It needs a major update.
self-hosting would be great but in live n a very rural area where internet packets are transported by mule so that option is out, A cloud platform is needed.
I will try this tutorial next time

Thank you for sharing what did it.

That FF error sounds like it’s for a bad certificate (though obviously i’d have to see it :P). It could be Lets Encrypt wasn’t configured correctly so there may be no encryption.

You can use this tool to check if Lets Encrypt granted you a certificate for your domain this week. Just search for your full domain + sub domain (ex: meet.example.com)

yup. thanks for the tool website, The certs are valid. They are there. Renewal is in 89 days. The errors in FF might be a result of my security settings. I have FF really locked down. Also, I changed some requirements in /etc/jitsi/jicofo/sip-communicator.properties to require userID and passwords.

1 Like