Inspiron 5593 Woes

Device name Dell INSPIRON 5593
Processor Intel Core i7-1065G7 CPU @ 1.30GHz 1.50 GHz
Installed RAM 16.0 GB
Graphics Intel Iris Plus
Storage 512GB SK hynix NVMe

I have this Dell I acquired about 2 years(?) ago and despite it seeming to have pretty bog standard hardware, I’ve had a hell of a time getting various distros to work past about three boots. As it initially came with Windows 10, here’s my usual process for Linux installs:

  • Disable SecureBoot
  • Disable TPM equivalent (PTT)
  • Install and update a distro (Fedora, Pop_OS, Zorin, Manjaro/Arch BTW)
  • Reboot, configure, install things.
  • ???
  • At some point past this when I reboot I get a grub> command line prompt and it refuses to boot. Often the error message is “you must load the kernel first.”

Sometimes when I reboot a few more times I get it to load up. Other times, it just stays in that loop. Since Fedora has supported SecureBoot in the past I’ve tried leaving that on when I do the install and it still comes back with this error about loading the kernel.

Has anyone else run into this? I have an HP Envy and System76 Gazelle laptop that have no such issues despite having wonkier (nvidia) hardware in them.

Crap NVMe drive? Is it still under warranty?

Entirely possible, although the version of Windows it came with hasn’t shown any issues booting or being a daily driver. Warranty expired a while ago.

Weird that it initially works fine but eventually craps out. Not an expert but I can’t think of anything else that would cause that.

My System76 BIOS has that option, but I just dug around on the Dell and didn’t find anything like it. On the plus side, I found menus to disable Bluetooth and my mic/camera - which I’ve been meaning to do at some point. So I have that going for me, which is nice?

I have had to disable “SupportAssist” on this Dell before to even be able to boot from USB, so it’s possible there’s something in the BIOS settings I’m missing that’s doing an intermittent security check and throwing up when it doesn’t see what it expects. I haven’t had that problem with older Dells, but I wouldn’t put it past them.

I dug around in the boot menu on this point as well. This device apparently only supports UEFI. Could that be the issue?

Keeping in mind I’m making the ISO from Windows, would Rufus or Etcher allow me use GPT specifically?

Answered my own question - Rufus has a handy-dandy dropdown menu for MBR or GPT. I’m going to give that a try and repost (hopefully) from the other side once I have a working install.

1 Like

I’m interested in this, after reboots, you end up in a grub prompt meaning you probably lost your grub.config along the way. Is there anything you are installing that updates grub, or manipulates it?

also, what did you mean from ??? are you unsure what is happening here?

when you get to the grub prompt, have you tried to use a Live USB and possibly chroot or systemd-nspawn -bD into the system to investigate grub ?

It’s possible that the updates I’m installing are bringing in a new version of the kernel, and that’s updating grub. Yes, the ??? is because I’m unsure what’s happening under the hood.

1 Like

Cool, thanks. would you mind to do a nuke and pave again ? (complete reinstall on to the drive again )
1 Complete the reinstall
2 Boot into the fresh new system
3 immediately do dnf -y update once complete systemctl reboot
4 Upon reboot , Install your software choices

I’m interested if anything happens after this, maybe we can break down possible issues.

Okay, nuked and paved. Went with PopOS this time because I’m more comfortable with deb-based distros for troubleshooting. Ran an apt update && upgrade. Rebooted. No issues for reboot 1. Going ahead and installing my usual stuff. I’ll keep a reboot tally and post back if and when I get the grub prompt problem.

1 Like

I’m on reboot 4, and so far no issues. Perhaps choosing GPT when I made the ISO helped this time.

knocks on wood


The grub recovery console isn’t too hard to figure out. There’s lots of guides online. This can be caused if a partition changes on the drive that grub was using and is suddenly not there. Or a kernel update isn’t updating grub properly perhaps.

That’s my suspicion, currently. Thankfully I was able to upgrade to kernel 5.15 this morning and reboot with no issues.