HP new laptop trouble loading Ubuntu or Mint

Please provide as much information as possible to allow others to assist you. The more information you can provide the better.

  • Distribution & Version (ex: Ubuntu 18.04) Ubuntu 20.01
  • Kernel information (type in terminal: uname -A)unknown tried both Mint & Ubuntu
  • When did the issue start happening? 2 weeks
  • Did anything change that caused it? (hardware change, upgrade)New HP i3 laptop
  • What steps do you take that cause the problem?rreloads, change bios, mutiple distros

I have tried Mint, Ubuntu, PopOS and Manjaro. The HP doesn’t have the bios menu that all the internet sites claim it does, no option to change to legacy bios, no way to do anything but disable secure boot, most of the linux boot dvd/usb sticks don’t even recognize the internotal drive , so can’t set up dual boot. PopOS did load, but didn’t recognize the wifi card, I tried looking up drivers, but that is a catch 22. I can’t get internet if I do load linux, but can’t load to the windows partition and have the drivers available to th linux partition. I also tried install to an ext HD but again, the windows setup appears to be armored against recognizing the linux ext hd. I think I have to wipe the windows disk and install linux on the hd, but then have no clue how to either obtain nor install the drivers needed to recognize the realtek wifi card. I can post the specs to the laptop system if that would help, but didn’t want to post that long of a message.

Knowing the laptop model would help. I can’t promise that I’ll be able to solve your issue, but I will try.

1 Like

I know Mint can automatically detect whether it needs proprietary drivers and install them for you through the “Drivers” utility. I think most distros have this. You need internet for that to work though. You don’t have an Ethernet port or some other WiFi dongle to use temporarily?

imho… Fedora has the best driver support out of the box because they include the freedesktop.org drivers that aren’t in the Kernel. I don’t know if PopOS or Manjaro have those built in. It wont fix your wifi issue though (see below)

That’s very normal for Linux, almost all wifi cards require proprietary software that needs to be installed manually. If you want to make your installation life vastly easier you could buy a USB to 10/100 Network adapter and plug into your router or get a FOSS wifi device as either USB or a replacement card.

There’s a list of FOSS hardware sites here: FOSS hardware sources

Wikipedia has a great page on wireless compatibility by chipset: Comparison of open-source wireless drivers - Wikipedia

Small list of some FOSS wifi devices here: wifi - h-node.org

I haven’t had experience with any of them (yet) but they should be Linux plug n’ play.

The area of the harddrive that contains Linux (the partition) will usually be in EXT4 format or something else that Windows can’t read.

You can read EXT4 on Windows 10 but you need 3rd party software to do it. If you’re security conscious or worried about losing data I wouldn’t recommend this.


I strongly recommend running Linux from a separate drive. Windows is known for borking dual boot systems during updates and it’s not great for security especially with Secure Boot off and if you’re not using Full Disk Encryption.

You can remove the Windows drive and replace it with a Linux one. That way if you need to sell the laptop you just swap them back.

If you still want to run Windows, you can buy an external drive and run Linux from USB. Preferably 3.0 or Type-C for a pretty good experience.


I’ve been doing some sniffing around the wireless options because i’d like a FOSS compatible wireless device too.

Using wikipedia’s page to cross-reference the best of the known chipsets against the best of the known driver capabilities and requiring the driver exist on both tables, the best FOSS chipsets within that comparison are using:


  • Protocol(s): a,b,g,n
  • Interface(s): PCI, Mini PCI, Mini PCIe, AHB
  • Chipset(s): Qualcomm Atheros chips with IEEE 802.11n support


  • Protocol(s): a,b,g,n
  • Interface(s): USB
  • Chipset(s): Qualcomm Atheros AR9271, AR7010 (USB-PCIe bridge with AR928x chips)


  • Protocol(s): ac
  • Interface(s): PCI, Mini PCI, AHB, Mini PCIe
  • Chipset(s): Qualcomm Atheros chips with IEEE 802.11ac support


Cross-referencing with h-node.org’s list of devices, there’s two matches for the Atheros AR9271 chipset tested on no less than Trisquel! (it’ll run anywhere):

TP-Link TL-WN422G v2
TP-Link TL-WN322G v3

Both ThinkPenguin’s USB choice: TPE-N150USB and Technoethical’s USB choice: N150 are also using the AR9271 though ThinkPenguin also sells several wireless cards with different chipsets too.


ThinkPenguin’s TPE-M2NCRD2 is using the Qualcomm Atheros QCA9565 chipset which isn’t on the wikipedia page or h-node.org though ThinkPenguin says it’s firmware is FOSS and it’s “uniquely supported across all distributions” though they also warn:

Notice: Many Apple, HP, Lenovo, IBM, Dell, and Toshiba branded products are defective by design. They use digital restrictions management technology and proprietary connectors to limit what hardware may be installed. This is usually a digital restriction in the BIOS that prevents the otherwise standards compliant M.2 slot from accepting anything but wifi cards sold by the PC manufacturer. If you have a problem with this please contact support to return or exchange the product within 14 days. For impacted users we recommend a USB wifi card instead.

1 Like

Am I allowed to mention ndiswrapper? Delete this post if necessary. I used to use this in the mid naughties but haven’t needed it since, hence I cannot remember any details of how to use it. But a quick search shows its still “a thing”.


I’d go out on a limb and say the odds that the proprietary drivers aren’t in the repo are pretty low though it’s a good read on NDISwrapper and an option of last resort thankfully i’ve never had to use. :stuck_out_tongue:

I’ve struggled with systems like this in the past too.
Simplest, easiest way to tackle this is what @Ulfnic said, remove the hard drive and replace with a new one.
Then it’s onto installing the os. It helps to have a cable, that way, you can get the wifi drivers of your choice immediatly.

Hope this helps!

1 Like

When buying a new laptop for which one has paid a good chunk of the cost for Windows, it does seem like a shame to not dual-boot it to keep Windows there. In recent years my experience with this has been that some models have very limited BIOS/UEFI configuration options and that can make installing Linux extremely difficult if at all possible. Besides that, dual-booting Linux with Windows seems to be becoming harder and harder. Windows 10 has a hard enough time updating itself as it insists on doing, without crashing during update, without adding GRUB and dual-boot to the mix - and I’ve had it mess these up when it crashes too :frowning:

I hope you succeed in managing your needs. My own sad conclusion of late is to isolate my very limited Windows use to a machine I use for Windows only, and also keep a separate external hard drive for Windows use only. Otherwise there is the persistent risk that the unreliability of Windows could compromise whatever I’m doing on Linux (which is thankfully most things)!

I’ve had much success installing Linux on many laptops over the years but with my dads current laptop I just couldn’t do it. I had to give up on that one. Hes still rocking windows 7 which I am not happy about but that’s the way of it some times.

I hope Win7 is being supported by Internet Security firms, and he’s not having to rely on it for online banking, for example, when security could be a major concern. I understand the need to have to try to manage with older equipment at times too. I’m glad you’ve managed to get Linux working most times in the past.

Linux Mint did not even detect the internal HD but I did get linux installed on an external HD and I did order a dongle. Apparently, Realteck wifi cards are even worse than Invidia for lack of compatibility with Linux. If I can get the dongle to work as advertized, the problem should be solved. Thanks for the help.