Help on installing Fedora 34 KDE - dual boot UEFI Windows 10 on SSD

Have no issues setting up MX or KDE Neon in a dual boot situation with Windows 10 UEFI on SSD.

Not so with Fedora 34 KDE…

  • Check list in Windows BIOS:

  • -Shrink c drive to make room for KDE;

  • -Disable fast start up?

  • -Load in UEFI mode.

  • Check list on Fedora KDE installation:

Tried finding a tutorial for BTRFS.
Most often, just set the partition to root on other distros.

I thought the newest was Fedora 34 (and 35 alpha stuff).

How did you get a Fedora 40?

Hooked up a generator to the floppy drive and sent 1.21 gigawatts through a Red Hat 9 boot floppy.

You know, the usual way.


Probably got it in my dreams… sorry about that guys!

Hey friend, not to murder my jokes, but I understand you’re on the Fedora 34 (featuring GNOME 40). I don’t think anyone here is ragging on you for your Fedora related issues.

I’m not sure about the issues you’re running into because when I install Fedora 34 all I had to do was plug in my USB stick and boot from it and then install per usual. I was not able to replicate your issue on my personal computer. (This does not mean the issue is not happening.)

Perhaps this was not the thread to make cheap-*** jokes.

No offense PatPlusLinux!

I deserved the punch!

I don’t know what i did wrong last time (had to re-install Windows), so i just want to re-check my checklist to see what might i missed out on.

Does it not have a grub entry or it doesn’t boot or some other issue?

I have a “triple” boot machine with openSUSE, Mint and Fedora 34. Except that Fedora doesn’t get a grub entry for some strange reason. Is that similar?

From recent experience with MX Linux, ESP is default option which i choose and then set ext4 as /
Don’t bother with /home as Dropbox is still my main storage house.

There’s some empty bullet points at my side, tried on PC and phone :thinking:

Btw I’m also using Fedora KDE with Windows 10, how I partitioned:

  • Shrink Windows partition before installation.
  • Choose the advanced partitioning (Blivet GUI).
  • Create new ESP for Fedora, set mountpoint /boot/efi, yes I’ve multiple ESP on same drive to prevent any OS wiping others stuff.
  • Create boot partition (ext4), set mountpoint /boot.
  • Create Btrfs Volume, named Fedora without mountpoint.
  • Enter Fedora Volume at left-side panel.
  • Create Btrfs Subvolume, one named root mountpoint /, one named home mountpoint /home.

@leekaize - superduper! :cowboy_hat_face: :yum:

Sure isn’t a simple procedure for an average guy like me.

But, will give it another shot!

Btw, should secure boot be disabled?

If it helps, secure boot is pretty irrelevant unless you’re using full disk encryption with one or more of your OSs. If an OS can meddle with your other OSs directly it won’t matter if their boot process maintains integrity.

Btrfs partitions should be @root and @home shouldn’t they?

Talk about complications…

After 3 or 4 attempts at booting Fedora installed on usb (Sandisk) through various ports, still no go to get it up and running.

Checked UEFI bios manager and all that appears is “Windows Manager”.
On previous Windows installation, usb would appear along with a few other things (that appear in Legacy Mode).

So, how to add usb device on that UEFI mode is beyond my qualifications.

Worse comes to worse, can always wait for Q4OS to come out with Debian based BullsEye Windows installer…

That’s the way Ubuntu do it but it’s not a requirement. Fedora use root and home, I suggest that because IIRC Fedora 34 only enables zstd compression if you named Btrfs subvolumes root and home. Sure it’s possible to name it @root and then add compress=zstd:1 in fstab afterwards tho :slightly_smiling_face:

Do you mean you’re unable to boot the installation media or you’re unable to boot into the OS after installation?

Unable to boot the media.

Had burned the .iso with Rufus to Sandisk which works for most distros.

Btw, just tested with a Windows Media Creation tool install on usb and it loads.

So… maybe it’s time to try another .iso download and do a BalenaEtcher burn instead of Rufus this time around.

Managed somehow to get Sandisk on usb to load.
Don’t think it was a Rufus issue.

Was unable to do that last part “create Btrfs Subvolume… named home mountpoint /home”
So i tried with “root” one only.
It wanted password at boot to do some managing stuff - didn’t work.
Said enter ctrl+D to continue as alternative, and that didn’t work to get into installed system either.
So have removed Fedora.

Back to square one…

I guess the password thing you mentioned is for secure boot? I never enabled secure boot and never have a reason to.

And for the Btrfs, most probably you created a Btrfs Partition instead of Btrfs Volume. To create a Btrfs Volume you have to select it from the top drop-down, not the one selecting ext4 and stuff. (But as you’re just still learning this, you can just ignore some one these, most importantly is still to install the OS successfully!)

And BTW there’s a thing called Fedora Media Writer to use instead of Rufus and stuff.

Hope for the best to you :slightly_smiling_face:

You’re probably right leekaize!

In the meantime, i took a peak at this tutorial:

Maybe not the best way, but much simpler to follow.

Will get there!

And thanks for hanging around and your help! :slight_smile:

1 Like