Graphical compression/decompression of .zst files

I’ve been curious as to which graphical utilities for Linux desktops have got zstd support built in (to compress multiple files at a time). The default “Archive Manager” (3.30.1) which comes with my current MX Linux 19.2 XFCE doesn’t have zstd support yet.

After some searching, I’ve found and installed “PeaZip”, which is LGPL v3. It worked, however it was a bit clunky, because when you try to uncompress a .tar.zst (containing multiple files), you actually have to do 2 de-compressions. The first decompression merely extracts the .tar file. The second decompression actually extracts the multiple files out of the .tar file, like you were wanting in the first place. So that’s a bit awkward, but livable.

Note: It seems the gnome archive manager does support .zst files, but only in a newer version (current stable release is 3.36.4), which doesn’t yet come in MX Linux 19.2 (which is still based off Debian buster 10)! There doesn’t appear to be any snap for this newer version, either.

Anyone have any other graphical .zst file utilities they can recommend?

Xarchiver did better than PeaZip, for usability, and it was installable right from “MX Package Installer”. Peazip was just a random .deb I downloaded outside that Package Manager.

I’ve heard that KDE’s Ark is also capable of doing .zst files. But last I tried, it didn’t. Maybe it does in the newer ones.

Ark uses Libarchive so that is a good bet.

But whenever I try to open a .zst archive I get the message that the file is not supported. :frowning:
This is using version 20.04.3 of Ark on Manjaro.

Could be related to this KDE bug?

EDIT: I just spun up an Arch VM and had no problem compressing and uncompressing a .zst file with Ark.

Hm. That sounds likely…

So I went and installed MX Linux in a VM and I got xarchiver (sudo apt install xarchiver) to work. Neither Ark or the GNOME one seem up to the task.

There is a caveat. If you ask xarchiver to make a *.zst file (which is an option in the drop down) it will hang on adding files to the archive. You seem to MUST select *.tar.zst in the drop down.

In addition you will need to sudo apt install zstd in order for the zstd options to present themselves.

Everything works as expected. Tested on MX 19.2.

EDIT: I just saw that you already achieved this. I’ll keep the post up anyways.

1 Like

Yes, that’s what I did (but didn’t mention this). Thanks for stating this explicitly. :slightly_smiling_face:

I also had installed the zstd package in the past (for usage on the command line), before ever discovering xarchiver’s support for zstd. So, again, thanks for stating that package dependency explicitly.

1 Like