ESET For Linux - Anyone? (Anti Virus System Use)

Hey there Community :),

Right now, I’m trying to get an AV system worked on my workstation which is OpenSUSE 15.3.

However, I am having issues with this due to instructions provided by the provider for the service: ESET.

While their products are positive over the years for me, I am having an issue with the service on this OpenSUSE system. For honest sharing, I have never used ESET on a Linux system, so this is new territory for me. However, I am definitely interested in learning.

Working with ESET, they have shared provider articles for packages but they related to Ubuntu systems based solutions. Trying to work them out with OpenSUSE, I have attempted via CL and Yast2 > Software Management. However, the packages they have recommended aren’t recognized.

(Article: [KB5827] Installation error "ESET NOD32 for Linux needs the following packages to install: libc6-i386, /lib/" with ESET NOD32 Antivirus 4 for Linux Desktop)

The recommended packages are:

libc6-i386 & /lib/

The instructions that ESET has provided is related to Ubuntu related issues, and I have shared with them that this is not related to .rpm but for .deb systems but they seem to have a hard time understanding what I am explaining.

For some points to help on this, can others please share if they have used ESET on Linux before and their experience? Also, if not ESET what else do you use?

If you don’t use an AV, what are you using for a system level security monitor? If none, can you share why not, please?

Thanks everyone :slight_smile:

I’m not sure what the problem you are having is exactly but I tried this out on OpenSUSE TW. Right off the bat I get a warning saying I’m missing glib something or other and the installed doesn’t even run at all. So I used zypper to search for something like it.

If I install glibc-locale-base-32bit the installer seems to run just fine.

1 Like

Hey there Ethanol,

Thanks for sharing this information and providing a screenshot. The issue I was having was a lack of awareness on how to make this work forward and how to find exactly what I was looking to do to support the needs for this AV to work. However, using your example helped a TON.

Too, when I shared with ESET that they provided instructions related to Ubuntu and for years past release, they realized they had too and shared a more updated OpenSUSE/.rpm focused set of instructions.

I’m going to try this out shortly but atm, wow!, I am tired lol So, my eyes are blurry and unable to even understand what I am trying to accomplish lol.

I’ll give an update soon. Thanks for all of your help. I look forward to doing this project :slight_smile: