Dual booting; Ubuntu 24.04 overwriting stuff in Ubuntu 23.10

I dual boot two system:

  1. Ubuntu 23.10 on NVME booting and running from OpenZFS with the datapool rpool and the dataset rpool/ROOT.
  2. Ubuntu 24.04 Dev.Branch on HDD booting and running from ext4.

I have my VMs also on that NVME in a separate dataset rpool/vpool. The 24.04 system works fine, till I import (say mount & open) the datapool rpool to get access to my VMs. Conky crashes and I can’t use the terminal and Firefox anymore. However the Virtualbox VMs in rpool/vpool work as I expected.

Before switching back to my main system 23.10 I export (close and unmount) the datapool rpool. When I boot the main system (ZFS!), the system boots, but I can’t use Firefox anymore. Even if I “snap remove firefox” and “snap install firefox”, firefox still refuse to work, also after a reboot. I also had an issue with the firmware-updater, but that seemed OK after reinstalling that snap. Whatever I try Firefox is DEAD!

So it looks that some part of Ubuntu 24.04 gets confused about the location of the OS after importing rpool, so Ubuntu 24.04 (ext4) seems to attemp to update Ubuntu 23.10 (zfs; rpool). I did write a bug report on Saturday, but no reaction. Too strange ?? I worked in Software Development from 1969 till 2011 and this is probably the strangest error I ever experienced.

To get a working reliable browser again I installed Microsoft Edge, out of revenge and because it is more efficient with memory :slight_smile: :slight_smile:

Weird indeed. But I would classify you as being beyond the pale of the average user.

I tried Ubuntu 24.04 and it would never finish it’s install. It was hung somewhere. Since I knew I was sticking my neck out for being a couple of months early, I backed away and left it alone. Granted that was hard to do as I have a new machine that I want to put Ubuntu Studio 24.04 on as soon as it’s released.

Are there residual profile files left after the removal of FF that might be corrupted and be the cause of this issue? Maybe have a look in ~/snap/firefox/common/.mozilla/firefox and see if there’s oddity in there.