CES 2020, Disaster Recovery Tips, Fallback Safe Distros?, Firefox | Destination Linux 156


I’ve been using VirtualBox. I’d be interested in hearing more details of your conversion to libvirt and virt-manager. Did you run both virtualization products on the same PC during your conversion? Can a virtual machine be converted from VirtualBox to virt-manager?


@dasgeek Major retailers and manufacturers have long “conspired” to offer “special” models. Consumer Reports thought the purpose was to make comparison-shopping difficult. That probably explains Best Buy selling an HP laptop that “doesn’t exist” on HP’s own site.

Which doesn’t answer why it won’t boot Linux.

A friend recently bought a Dell Inspiron at Costco. Great deal, came with NVMe SSD. He wanted to install Linux and it just wouldn’t. His laptop chassis had space for a SATA SSD, so he disconnected the NVMe drive, added a SATA, and set that to boot. Which worked.

To sell Optane drives Intel developed a default RAID configuration. Optane made sense with HDDs, none with NVMe, but the configuration persists. Winders somehow manages to boot successfully in that configuration where, apparently, the Linux kernel doesn’t.

Here’s a Dell link that MIGHT be applicable and helpful. Though I’m presuming the HP went back to Best Buy.


@MichaelTunnell I know we’re all of us all in about privacy, but as I opened the DestinationLinux.network “portal” page today I glanced up and noticed uBlock Origin is reporting 32 what for lack of a better term I’ll call “trackers,” doubleclick, google, youtube ???

this is due to the video embeds of the YouTube videos. I set it to use the nocookie domain but something else is a miss. I will have to look into this.

1 Like

Hi Folks,
I’ve just listened to DLP #156 and have a couple of questions.
Firstly I second OldFart and would like to see more on this. I’ve recently switched to Ubuntu mate 19.10 and attempted installing. Previously I’ve always just installed Oracle’s Virtualbox… Upshot is I tried virt manager but it failed with the libvertd install. I’ve searched, but can’t find much on this issue. Any suggestions on a guide to follow to getting this to work?
Second question is around the new Dell XPS 13. I like that its got a webcam up top, but from what I can see, it doesn’t appear to have USB slot. How would one install a distro? via bootable SD card?
I do like the fact that it can be delivered with ubuntu pre-installed, but I would like to install my own.

Keep up the good work!

Scooter (on my thinking stool) :slight_smile:

regarding the XPS it looks like it has 2 USB-C ports so in theory with a dongle a regular USB-A flashdrive should work to installing a distro.

Thanks Michael,
Perhaps one of these might work? I really like this laptop, it may very well be my next purchase.

I’ve also managed to get virtual machine manager working. So far I’m liking that as well. Installing Fedora after listening to BDL

For Slack alternatives, while I haven’t used it myself yet, Taiga looks like a very good, Open Source solution and is gonna by my first try if I ever start any bigger project. Managing non-private projects is paid (5$/month), but if that’s a problem one can always self-host it.

What problems did Noah have with Jellyfin? I have mine setup via Docker, but it’s not on all the time and it’s only available locally. I was surprised he had so many issues he gave up!

1 Like

Thanks again, everyone. Really enjoyed this. @dasgeek Ryan, I completely agree with you on what you’ve said about Microsoft products on Linux and what you say about NVidia (versus AMD). Thanks also for supplementing what Noah mentioned about libvirt just a while back. I’m looking at moving all my VMs from Virtualbox onto libvirt. My early experience of this using the very basic Gnome Boxes was excellent. The worst thing I’ve found about Virtualbox is how guest additions keep breaking on kernel updates, especially on fast-moving distros such as Fedora. I also agree with Noah on how useful Fedora is. CentOS Stream is also turning out to be quite handy, as I’ve mentioned elsewhere on our forums.

Hey @OldFart I’ve got the same question now. Have you tried following this?
link describing vbox to virt-manager migration
It says it takes a while. I imagine it would need some disk space too. I haven’t tried this out yet, but I think I will when I get some time. I don’t really have much on my VM’s, I pretty much only use these to tinker with new distros. So doing a complete re-install in virt-manager wouldn’t be that bad for me.
I can understand that some folks may have a alot on their VM’s.

I’d feel more secure if I’d know if anyone’s used the clonehd command successfully before to get things going in virt-manager.
There’s more about this command here and here
Hope that helps, let us know how you go

@Scooter and @OldFart, if you need advanced functionality out of your VM’s, virt-manager is definitely the way to go, but GNOME Boxes is perfectly up to simple tasks. No need to be on GNOME either—it works just fine for me on bspwm.

Thanks for the links, @Scooter .

That first article is 8 years old, but it is close enough to the current syntax. I had to struggle a bit with reducing my virtual disks first. After that, the clonehd worked surprisingly well. Converted a Windows-10 vm and a Devuan vm. There are a few features that I haven’t gotten to work yet. virt-manager could use a ‘help’ button for access to the documentation. Most of the documentation that I’m finding on the internet seems to be out of date.

My converted machines lost several capabilities:

  • cut-and-paste clipboard
  • video resolution and auto sizing
  • shared filesystem subdirectory with host machine

I might have lost more features, and I might find fixes to the features that appear to be missing.
I’m out of time to play with it tonight, but I’m not giving up.
. . .
My update on 01/21/2020:
spice-guest-tools from spice-space.org does add bi-directional clipboard to Windows 10 guest.
However, their webdav add-in to read-write a shared folder on the linux host is cumbersome compared to VirtualBox since it only works while a virt-viewer session is open. I shouldn’t be surprised that the conversion broke Windows Activation. The activation problem might also explain why the video resolution and resizing doesn’t work. This activation mess might be enough hassle to force me back to VirtualBox.

Didn’t have much time to play with my linux guest machine. The 9p filesystem mounted the folder shared from the linux host, but I haven’t found a configuration that grants the correct permissions.
I assume that I need to install spice video drivers into the guest, but I haven’t figured out how to do that yet.

1 Like

Nice work OldFart.
I agree there is so much old doco that doesn’t quite work for me either
Glad this was helpful for you.

I don’t really have a need for it but I tried Mattermost just to play around with it and it seems like a reasonable, open source alternative to Slack.


agreed, Mattermost is the closest to an alternative to Slack at this point. There are many others but Mattermost is the closest.

I haven’t tried Taiga yet though.


I’d also like some help setting up VM’s in Virtual Machine Manager. At first glance it’s very plain and confusing.

Hi Definitive_Linux,
Searching Youtube for virt-manager was helpful to me. My installation is working pretty well for me now, but I’m no expert.

Have fun with it.

1 Like