Arch install, unrecognized filesystem ext4

I’m not new to installing Arch but this is a new problem I’ve never seen before. I’m 5 minutes into the installation here where I mount the partitions. I formatted the whole drive GPT, two partitions, sda1 and sda2. Sda1 is UEFI boot formatted as fat and sda2 is formatted ext4. I used cfdisk to format. Now I’m trying to mount the partitions and that fails because ext4 and vfat are not recognized filesystems.


I’m no kernel module expert but I tried

Modprobe ext4

Modprobe ext4.ko

Modprobe fs

All of which yield a “FATAL: no module found in /lib/modules/5.7.6-generic”

Seems like something is completely buggered with their iso.

First off, did you verify your download before flashing it? It’s possible you got a corrupt ISO. Secondly, you did remember to run mkfs.ext4 /dev/sda2 before trying to mount it?

Yes and yes. I’m using the 2020.07.01 iso here. I downloaded and tried the 2020.05.01 iso and that works as expected, except the live usb disc runs out of space when running a system upgrade before installing to the mounted partitions. That is an issue that did not occur with 2020.07.01 iso.

Why are you running an upgrade on the live environment? That sounds like a great way to eat up your ramdisk.

Yeah, no idea. I have 3 different OS installs rolling around my brain, I guess I decided that’s when I should do that. Pretend that never happened.