Apex Legends now runs on Linux with EAC

Ok guys, don’t panic, but it’s happening:

The first reviews on ProtonDB seem to indicate that everything is indeed working fine, with stutters due to shader cache compilation, but no other issues. Am downloading it to test it myself and trying not to get too excited, but holy hell, this is huge!


I’ve seen that on Reddit too, people reporting there that it works. Finally I can play Apex again. Actually Apex was one of the reasons why I kept a Windows installation (but actually never boot into it other than updating, for years!). It is weird to say, but I like EA nowadays for their games being playable on Linux (what a low bar :smiley:).

Is this the year of Linux?


If only WB would get Mortal Kombat 11 online and story mode working. . .

I saw @JasonEvangelho tweet about this. Started downloading right away 'cause I have some friends who play it.

Yep, it prompts you for login when you first launch the game.

tbh same, I only have their account still due to getting some free games over the years and sharing it with my best friend

I just downloaded and run Apex on Linux and there was no prompt for login and I had not needed to enter any account data. My guess is, that these data are saved from previous playing on Windows when it launched on Steam 2 years ago or so.

It probably recognized your steam account. I’ll give this a try since I haven’t run the game through steam before

I believe you can sign in with your EA account to get the progress you have. Or you just start a new account that is automatically created when you choose Steam. Even without a launcher, the game logs in when you started the game itself. But this is highly speculative on my part, because I don’t remember.

Unfortunately it’s completely unplayable for me. Shader issues I believe. Tutorial worked fine but online most of my screen is flickering black.

That is unfortunate. Maybe you need to wait until the shaders are generated in the cache. If you still want, open Steam, go to Settings > Shader Pre-Caching and enable both options. You can even watch which shaders are currently generated. I was taking this screenshot and noticed a few game titles there, including Apex: https://i.imgur.com/coCKkiB.png

Then when this has been done, run the game again and maybe wait 5 minutes, just to be sure that everything is done. If you still experience these shader issues, then maybe it is a different problem for you. I got a few stutters in the beginning and then it goes away, even on a Nvidia card (1070).

I’ll try that. Pre-caching was already on but not the Vulkan background processing. Unfortunately I can’t tell if the issue is solved until I’m in game and then I basically run around blind or just leave the match which is kinda BM.

You can first enter the training area without online play. The menu is a bit weird. On the left bottom image above the Ready button https://i.imgur.com/WCYNKkK.png, if you click it you can change the game mode. The training where you can freely shoot with weapons is called Firing Range and is located on the top left: https://i.imgur.com/ulx5ylP.png (Training is I think the initial tutorial? So just use Firing Range.)

At least you can make sure that the game works before entering a real match with other players.

The training and firing range work perfectly. It’s the online that doesn’t work for me. It seems to be the worst in Kings Canyon. I got through a few rounds on a different map where only a few textures were missing.

I only played a few 3v3 matches so far in the little area, no Battle Royal currently. I’ll report back on the Battle Royale when I try it out, now that I have more time.