AMD problems with Ubuntu on Dell Inspiron laptop

Sorry… I don’t seems to advance much.

My first idea, is that you could try to run (while in nomodeset mode):
sudo apport-cli
yourself… you might be able to let it upload the crash to let it regenerate the backtrace (often it is not able to get the symbols right locally).

Then you could try Groovy Gorilla beta version (that will become 20.10 soon):

Or strangely try to use 18.04… people seems they were able to use your laptop model with it in the past.

Last, probably your son would not be so sad with Windows. :wink:

1 Like

Thanks @dufresnep I’ll try all your suggestions and will let you know.

So weird!
Can’t seem to get any of the options on the crash report cli to go anywhere. It just seems to freeze on a terminal screen full of dots.
So it’s 18.04 time…
One attempt using an 18.04 live usb works and the live usb boots to both monitors. I’m feeling a little buoyed with hope that it will work.

I then get cold feet or confident that I can fix 20.04 and go back to the 20.04 install. I muck about with grub for a bit then think… to heck with it! I’ll just have a crack at installing 18.04
This time I just get a blank screen and the very same 18.04 usb only boots to blank screen.

edit… Ok so I persisted and 18.04 seems to be stable on this laptop so far.

I can reboot and both monitors are picked up. Solved? in an odd way.

Forgot to mention I tried 20.10 beta but live usb didn’t show the second monitor. :frowning:

1 Like

I’ve run your suggested freedesktop script again on 18.04 after logging in the morning to only a single monitor. :frowning:

Here’s an interesting warning message after running
sudo /usr/sbin/update-initramfs -u

W: Possible missing firmware /lib/firmware/rtl_nic/rtl8125a-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168fp-3.fw for module r8169

Thanks @Scooter and I need to bare that in mind.

I’ve used the freedesktop drivers on 3 different devices and it’s always gone off without a hitch. In 2 cases getting me into X where before it was hanging and in the 3rd case boosting performance. By your input that is obviously me getting lucky and in all 3 cases the hardware was pretty new and I was applying the drivers to a pretty recent kernel.

On the errors: Looks like you’re missing drivers for your Realtek network device. This may solve it for you:
sudo apt install firmware-realtek

1 Like

Arch wiki has a page on my laptop

This also references another useful page

Noticed that my ubuntu (semi) working install is rev c3 not rev c4.

04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c3)

more to research and try
11 yr old son is still happy for now with the 10yr old Toshiba laptop so I’m continue tinkering… I just want this Dell to work normally…

As an aside, while I find this frustrating that it doesn’t work. I’ve noticed that this sort of “quest” to find a solution is one of the reasons I love Linux. I’m usually good at ferreting out solutions. It’s what I do for a living pretty much.
What’s irritating is that there isn’t a single place to go to for answers and sometimes I don’t really know what to search for.

1 Like

Been tinkering with the laptop again. Ubuntu Mate 18.04 even trying Groovy Gorilla on for size, came close, but it still wouldn’t give me the second monitor. :cry:
Last night I loaded up a usb with the latest Manjaro iso (20.1 Mikah running KDE) and everything just worked.

Just in the process of restoring all the save game files and poking around with a few theme settings. I think my son will be ok with it.

So now both monitors (laptop and external) work fine.
I do remember trying Manjaro out some time ago on this rig and it wouldn’t play ball. Nice to see it working now.

Very Nice! :smiley:


Now try getting Valve’s Steam on it.

What about trying Debian? I know Steam will install on it.


Linux users are best categorized as people who just don’t know when to quit. :slight_smile:

That’s quite a lesson of perseverance for the kiddo.

Debian sid might get your there too but Manjaro’s well loved for good reason. Enjoy the victory.

You said it @Ulfnic I just have to solve the problem. : )
Sometimes ‘do nothing for a while’ gets results. :smiley:
My son still had the old clunker Toshiba and was happy with that in the mean time.

Also @Trent I’ve not had a problem with Steam running on Manjaro it works a treat!

1 Like