Wierd freesync problem

I have a rather strange problem, but before i get to that i will provide some info about my setup.

I am running:

OS: Manjaro Linux 18.1.1
Kernel: 5.2.21-1-MANJARO
DE: GNOME 3.34.1
CPU: AMD Ryzen 7 2700X (16) @ 3.700GHz
Memory: 3238MiB / 32149MiB

1x AOC Agon 27" 144hz Freesync 2.0 HDR
2x Samsung S27D590 60 hz

For some reason, i have to restart Gnome shell before playing my games or freesync wont work. I have been testing this with Minecraft for a couple of hours. And the problem is consistent. If i launch any app, doesent matter which monitor i use, i have to restart the shell.

Any ideas? I know that Multimonitor setups with only one freesync panel will cause issues. But it works flawlessly if i restart the shell.

That’s awesome setup @TeknetDaniel I’m looking to get AOC Agon myself. Sorry I can’t help you I don’t have Freesync Monitor right now. Hope you get it sorted out thats nice setup

1 Like


Tried switching kernel to 5.4 and the issue is solved. Dont know why, but it is.