The App Paperwork can not see my combi Scanner/printer on Mint

I am fairly new to Mint, and have run into a problem.
I have just upgraded my old Dell laptop to the newest Mint 19.3 Cinnamon
Via the Software Center in Mint, I have installed an App called Paperwork. And app to scan and organized documents into searchable PDFs.
I have an old Cannon MG2400-sries printer/scanner.
I can print documents, and SimpleScan also work.
But Paperwork do not find my printer/scanner?
When trying to scan, a popup comes, saying;

No scanner found.
You use Paperwork from Flatpak container. Paperwork needs Saned to access your scanners. To enable Saned on the host system, you can use the following commands;

Code: Select all

sudo apt install sane-utils
sudo sh -c "echo >> /etc/sane.d/saned.conf"
sudo systemctl enable saned.socket
sudo systemctl start saned.socket

I have tried to put the commands into the Terminal, but it do not help.

I hope somebody have an easy solution to this problem.
Thank you for your time.

Best regards and merry christmas

I don’t have a scanner to test this but a couple questions come to mind. One, what kind of scanner do you have? I wonder if it might need a driver to work properly. A second thought I had is if you tried using Simple Scan which should already be installed. See if that works. If so, maybe it’s Paperwork.

I have a Canon MG2450 printer with a integrated scanner.
Mint have identified it as a MG2400-series.
I can print documents, and I can scan in Simplescan, so the device and the connection seems to work.