[Solved] Newbie here. Ubuntu 21.10. FreeFileSync unable to access directories

Error details here → https://imgur.com/2WeHC5w.png and https://imgur.com/78LkJ1w.png

I’m using the paid version of FreeFileSync. I’m able to open and navigate these directories using the gui file manager. This was working fine until about 6 days ago. Don’t know what could have caused the error.

How to fix this?

I’m not familiar with that program or your interface but here’s what I could say…

It looks like something has been mounted (im assuming a 2TB drive) under “advait” and is acting as a backup. Depending on how a device is mounted it may not grant certain users permissions to view it.

If it was working before, i’d first try to repeat the steps of how you mounted the drive the last time it worked after a reset.

If that doesn’t work you can try changing the permissions of the folders or make it auto-mount correctly using fstab.

While I’m not familiar with the program, I think @Ulfnic is on the right track here.

If you don’t mind, let us take a look at the contents of your fstab file. What do you see when you run the following command:

cat /etc/fstab

Mounts in /media mostly are done as a user so wouldn’t be in fstab.
I suspect that the program is running as another user than the mount of that volume.
If right are standard 755 the program wouldn’t have permission that do stuff.

I got it fixed. I changed “Ishvara2TB” to “Ishvara2TB1”. Now it matches the location of the directories in /media. That fixed the issue.

1 Like