Screenshot weirdness

This one has me baffled but I’m sure there’s a logical explanation that I’m missing.

I recently rebuilt my Arcolinux Plasma install and I’m trying to get a screenshot tool working. Normally my go-to is Flameshot. When I installed it and tried to take a screenshot the screen it displays is an old window with a browser/tabs that I had opened up days ago and obviously the wrong date/time.

I thought it might just be a weird bug with Flameshot so I then tried to install Ksnip. Ksnip is doing exactly the same thing, crazy stuff. It doesn’t seem to be consistent either - sometimes it will show an old browser window, sometimes it will show just my desktop - but again from an old day/time.

It’s almost like it’s grabbing an old screenshot from the clipboard or something but I’ve cleared the clipboard completely.

Has anyone seen something like this or have any suggestions?

What GPU do you have? Are you on Wayland or Xorg? (you can typically check this with the command echo $XDG_SESSION_TYPE)

Intel Iris iGPU and I’m on Xorg.

Also I should note that this all worked perfectly on my previous Plasma install as well as other distros I’ve tried on this laptop.

Mh, this looks very weird. As a troubleshooting step, try installing a simple desktop environment or window manager (I typically like openbox for these kind of tests) and see if you can reproduce this bug.

If you can, then there’s either something wrong with your hardware, your distro configuration or your drivers.

If you cannot, then I guess it’s a bug in plasma? I’d blame the compositor for this kind of behavior.

Also, try using scrot for screenshots and see if it causes the issue as well

I think it’s more likely it’s grabbing old content that’s still present in the VRAM. But with this kind of issue you usually get a glitchy mess of old content and random garbage

Scrot is doing the same thing, haha. There’s two or three screens that it swaps between (the old images) and picks them randomly.

I might make up a live USB of something first and check that just in case something has gone haywire with hardware. If that works fine I’ll try Openbox or another WM on this install.

Thanks for the suggestion

It doesn’t do it under another distro/live USB. It’s something to do with this install, which is strange as it’s a fairly fresh install.

EDIT: figured it out. I had to remove the xf86-video-intel package. I used to do this after a fresh install with Arch as I would have glitchy graphics and this was the fix. On this latest install the graphics seemed fine so I didn’t bother uninstalling it. After removing that package everything runs perfectly again. Thanks again for your help!


Glad you solved it!