Samba file server help


I have set up a samba server which was working just fine until I had to move the VM over to another ESXi server. Its running ubuntu 20.04 server.

I have tried to fix it I haven’t got a clue whats going on. changing passwords added new users and am just having a nightmare as it has all my client data on there. I can see the data with no problems in the terminal via putty on my windows machine.

The issue is when i try to connect to it via my windows machines it asks for the username and password. i tried everything i can think of and reset passwords on the samba server so i know what they are but its just not working i can see the server in file explorer (image attached)


But for some reason when i click on it to enter the username and password i just get

i have setup 3 users now and all 3 it says the same.

my smb.conf file looks like this and its worked fine before.

I have tried creating users for example dave and network are new users to see if it was an issue with the mason64 user. i tried adduser “network” and then passwd network and added a password

i also added the user to smb by typing smbpasswd -a network and entering a password (and the same for dave and mason64 users)

i have also added the windows feature smb 1.0/CIFS file sharing support on both my windows machines.

I can ping the servers address fine so the connection is fine. i can also ping any external or internal ip from the server in the terminal via putty.

When doing testpram i get the following

I know i can create a new vm server and then transfer all the data but i dont want to me beat i want to fix it! :slight_smile:

Any help would be brilliant!

Thanks and sorry for the long post, i hope i have even all the info that is needed.