(Resolved) ThinkPad T510 is using llvmpipe for graphics instead of Intel HD

Figured out the cause. Turns out that Mesa 22 dropped support for legacy graphics hardware, which includes my ThinkPad T510’s 1st gen Intel Core.



My T510 was upgraded with a Intel Core i7 640M. I discovered that it’s using llvmpipe instead of Intel HD for graphics, and I don’t know why. I have everything related to Intel graphics & mesa installed on the system.

$ sudo lshw -c display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1600,2700
       resources: irq:27 memory:f2000000-f23fffff memory:d0000000-dfffffff ioport:1800(size=8) memory:c0000-dffff
$ DRI_PRIME=0 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: llvmpipe (LLVM 13.0.1, 128 bits)

I tried both 5.15 & Liquorix’s 5.16 kernels, along with Mesa from the Ernst’s Mesarc PPA, but none worked. Funny thing, though, Mesa in Ubuntu repo wasn’t working properly (constant freezes), and necessitated me to add that PPA.

OS: Kubuntu 22.04

Good catch!

I believe the i7 640M (HD Graphics Ironlake) should actually be covered under the new Crocus driver so your performance shouldn’t suffer.

EDIT: I’m not actually sure the driver change is automagic. You might need to explicitly tell Mesa to use the crocus driver. YMMV.

You should try setting the MESA_LOADER_DRIVER_OVERRIDE=crocus environment variable.

That laptop’s being used when I’m running on the treadmill, so I have no urgency to re-enable his PPA yet.

I am willing to give it a try, but only when I got time to spare.