Random blank screen with AMD Ryzen 3200g

After a about a decade with my old system, I had it. 8GB was not enough memory, especially when both my wife and I were logged in each with dedicated X session, and my motherboard memory could not be expanded.

There are only so many DL episodes one can listen to before coming to the conclusion that AMD is the way to go. But since I am no gamer, and my power supply is rated at only 400W (a decade ago I thought it was plenty) I went the integrated graphic route:

  • CPU: AMD Ryzen 3 3200g
  • Motherboard: MSI B450-A Pro MAX
  • Memory: 32GB DDR4 3200Mhz in 2 sticks of 16GB each

Many moons have passed since I last replaced a motherboard, so it took me some time and lots of manual and youtube consulting, but I finally got everything to work… well…

From the get go, my Kubuntu 20.04 had a display issue. Periodically, after between 5 minutes to an hour, the screen when blank, sometimes with some green pixels at the top row, sometime not. Sometimes the screen color change its shade of gray when I move the mouse. When this happens the only way out was to kill the X session with Ctrl+Alt+Backspace, or restart the computer.

The only workaround that prevented this was to use the nomodset kernel parameter, but this degrades desktop effects, and worst made it impossible to use a dual monitor setup.

See this ask-ubuntu q&a

Other things I tried but did not work:

  • disable IOMMU in the BIOS as well as using the iommu=pt kernel parameter.
  • install the latest kernel from the Ubuntu Kernel Team

I must say I am disappointed. From @dasgeek and co. I got the impressions that AMD should just work. This is why I picked all AMD solution. Also this CPU is not new. It was launched a year ago. But even with the latest kernel this HW is still very flaky on my system.

Of course, I can’t rule out that I got some bad HW or that I did something wrong installing it. Am I the only one with this issue?

Are you experiencing the same issue with another DE?

Just a hunch, try KDE Neon

Everything I read so far suggest this is a Kernel & Driver issue and not a DE issue. I also don’t want to switch distro nor DE on my main system, and my wife will object too. However I can ran Neon in a live session, just to rule this hypothesis out.

Hi, welcome to the forum!

So, judging from the symptoms of your problem it’s quite obvious the issue is related to the graphics.

AMD graphics are always evolving on Linux, and every new version of the kernel and/or mesa bring huge changes. I suggest you try using a live usb with Manjaro as it should have newer kernel and mesa stack, and see if you still get this issue.

If you do, I think there could be something wrong in the hardware. Maybe you just got a faulty CPU and/or motherboard. MSI motherboards don’t have the best reputation for reliability afaik, and maybe if the problems persist you could try RMAing both the CPU and the motherboard and try another brand motherboard with the same but new CPU.

@YamiYukiSenpai, I am writing this message from the latest KDE Neon. So far it has been about 3 hours and no blank screen yet. I do get some display glitches, but this looks like adding iommu=pt should resolve this.

This, however changes two parameters:

  1. The KDE plasma version is on Kubuntu is 5.12 while it is 5.19 on KDE Neon
  2. KDE Neon is based on Ubuntu 18.04 and uses kernel 5.3, while Kubuntu 20.04 is using kernel 5.4.

IMHO, the Kernel version seems the more significant change.

@gabmus, it seem to me that in this case upgrading the Kernel gives worst results. I am specially frustrated since after a year of this CPU on the market, the latest kernel still has significant issues.

What sort of glitches? Like screen tearing?

FYI, both Kubuntu & Neon are using 5.19. The main difference, other than their base, is that Kubuntu is using Qt 5.12, while Neon uses Qt 5.14. This means that Kubuntu will be stuck with Plasma 5.19 until 20.10, which (presumably) they’ll move up to Qt >=5.14 in order to use Plasma >=5.20.

I just finished installing a freedesktop.org driver on an AMD 2200G (Raven) machine which couldn’t boot to a DE without it. It’s now working perfectly with high FPS.

Your AMD 3200G appears to be Picasso:

Ryzen - Wikipedia
AMD Ryzen 5 3400G review - CPU-Z Screenshots & System

freedesktop.org’s list of Radeon ucode:

Index of /~agd5f/radeon_ucode

This would be the installation for a Debian system, adjust if required:

mkdir ~/picasso_ucode
cd ~/picasso_ucode
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_asd.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_ce.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_me.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_mec.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_mec2.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_pfp.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_rlc.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_sdma.bin &&
wget https://people.freedesktop.org/~agd5f/radeon_ucode/picasso_vcn.bin
sudo mkdir /lib/firmware/amdgpu
sudo cp *.bin /lib/firmware/amdgpu
sudo /usr/sbin/update-initramfs -u

1 Like

Sometimes I get this artifact on an entire screen.

I see this even-though I disabled IOMMU in the bios.

@Ulfnic, thank you for your advice.

I did follow the procedure you suggested, unfortunately this did not solve my issue.

Damn… this may not be useful but perhaps try a few different live distros to see if the problem persists? Perhaps try Kubuntu 20.04 live as well to see if it’s something you configured. That way you can experiment without changing the installation.

I have made some progress with this issue:

Whenever I got a new update for the kernel or the X-server (including the latest HWE), or to my BIOS, I tried to remove the nomodeset from my kernel parameters to see if this problem resolved itself. But so far I could see no improvement.

I did however the following experiment: I made sure I know how to take a screenshot with my eyes closed. Then after getting a gray screen, I used that keyboard sequence after which I killed X. Looking at such a screenshot doesn’t show the gray screen I see, but a normal X session.

Next I started to play around with the definitions in System Settings > Display and Monitors > Compositor > Render Executor and set it to be XRender.

Both OpenGL 3.1 and OpenGL 2.0 gave me the gray screen, but now this no longer happens.

This is fine, but now I get screen tearing, which none of the options in Prevent screen tearing (“vsync”) helped me to resolve.

Any idea what is going on here?

As suggested by @LinuxUser, I followed the instructions in this Ask Ubuntu Answer. It points to a linux-firmware update. And indeed version 1.190’s changelog has:

  • amdgpu: update navi10 firmware for 20.30
  • amdgpu: update navi14 firmware for 20.30
  • amdgpu: update picasso firmware for 20.30
  • amdgpu: update raven firmware for 20.30
  • amdgpu: update raven2 firmware for 20.30
  • amdgpu: update renoir firmware for 20.30
  • amdgpu: update vega10 firmware for 20.30
  • amdgpu: update vega12 firmware for 20.30
  • amdgpu: update vega20 firmware for 20.30

As far as I can tell, Picasso is the code name for the processor family my CPU is part of, and although I couldn’t find vega 8 in the list above, I figured that it is worth a shot.

The package for Ubuntu 20.10, was installed cleanly on my 20.04 with HWE, and here are my results so far:

  • When I set my render engine to OpenGL 3.1, I did get the original Gray screen, however
  • on XRender, so far, I didn’t get any display glitches. :crossed_fingers:

Will keep posting about any updates.


This didn’t resolve my issue, I can still see from time to time the same glitches as shown :point_up:

Does this happen on all your monitors?

It certainly happens in my main monitor, as for my secondary one, I can’t say: it used to happen on it too, but for some time now I didn’t see any artifacts on my secondary monitor.

Have you tried swapping the cables?

Good idea.

It took me a while since my secondary display has only a VGA connection. But it seems that the graphical glitches are most common on the screen I am interacting with right now. When I tried to work more with my secondary display it too got those graphical glitches.

Well, it seem to be my fault.

Meet my culprit:

A cheap 4 USB Port PCI-E card that never did work properly (at least not under Linux), and I used as a somewhat awkward power bank. It seems that this card generated some electrical interference that caused my graphical issues.

The thing that through me off, was the fact that with the nomodset kernel parameter I had no graphics artifacts, so I figured this was a driver issue and not a hardware issue.

Since I gave up on my integrated graphics, I asked for a recommendation of a cheap discrete graphic card, and @Ethanol suggestion a used RX 550 GPU which I was able to find.

Installing it, however was an ordeal. It refused to work properly. I thought that I got a bad unit, but as a last resort (which I should have probably needed to do as my first step) I decided to try and disconnect all unneeded peripherals. Once I disconnected the offending USB card things started to just work.

Now I am happy using my newly purchased card. although I can just as well can use the integrated graphics.

Thank you all for your thoughtful suggestions.
This issue is now resolved.