Hey DL Network! I got my Braveheart PinePhone last week and have started confirming and testing bugs on the Community port of PinePhone for UBPorts.

I wanted to touch base with anyone here and see if you all are testing the PinePhone as well! What are your thoughts? Have you contributed to Ubuntu Touch as a project, or specifically to the PinePhone community port (or another distro)?


I wish! Money’s been really tight lately so I haven’t been able to splurge on things like the Pine devices. I have tried building UBPorts for some of my current Android devices to no avail so far, but since I’m not much of a programmer I haven’t been able to do much in the way of contributing workarounds for said devices.

1 Like

I have mine as well Which I have been enjoying hacking on getting postmarket OS with Phosh working gnome Podcast as well :slight_smile: woo this fun


I’d love to know how well some apps I made work on the pinephone. Here are some links:

  • HydraPaper wallpaper manager
  • Feeds RSS/Atom reader
  • What IP network information tool
    • Website
    • Flatpak NOTE: this link is broken at the time I’m writing this as What IP is still not on Flathub. Consider this as a future reference.
1 Like

Thanks everyone for replying! I’m stoked to see other people testing the PinePhone too!

@gabmus thank you for linking these apps you’ve made! I’ll download them on my device and test them out. Where would you like the feedback and logs?

If the apps work fine there’s no need for logs, just want to know how they work :grin:

1 Like

I guess it would depend on the OS they use on the PinePhone. I mean Ubuntu Touch might work with Libertine but not sure what level support the other OS’s have at the moment.

1 Like

What’s Libertine?

it is a cool system to install Linux apps inside of Ubuntu Touch because Ubuntu Touch has its own app model separate from Linux general apps. I am certainly interested if the RSS Reader works on it or not, that be cool.

@MichaelTunnell I can say for sure that Libertine does not work on UT on PinePhone :frowning:

Ideally you should be able to just use flatpak to install my apps. Don’t know how that works in ubuntu touch tho…

1 Like

I’m working on getting Flatpak to work on the PinePhone. It’s not as straight forward as I would expect. Flatpak complains that the phone doesn’t have space so I’m working on setting up a separate installation on the micro SD card. I have Flatpak installed and it can reach “Feeds” (your app), but once I work out the kinks with the error “Writing content object: min-free-space-size 500MB would be exceeded, at least 4.1 kB requested” and the warning that there’s not enough disk space to complete this operation, I hope to have good news regarding testing the app. Found a work around here: [Feature Request] Install Flatpak apps on custom locations (eg external disk drive) · Issue #1224 · flatpak/flatpak · GitHub

Also, considering some of the old posts on UT forums regarding Flatpak support, I’m not optimistic Flatpaks will work on the PinePhone, but I’ll keep trying.

If you’re trying using the command line, maybe you want to use the --user flag for flatpak commands. It uses the home directory instead of the root to install apps and dependencies. The whole setup procedure should be something like:

flatpak --user remote-add --if-not-exists flathub
flatpak --user install flathub org.gabmus.gfeeds

Thanks for the suggestion. I gave this a try and I get the same error with the --user flag. The first line completed successfully, but when I went to pull down your gfeeds app with --user, I get the same error message.

I think it’s time to open an issue upstream! I’d start with ubports, then flatpak.

Got mine in, but haven’t gotten to mess with it too much yet. Installed Postmarket OS with Plasma DE first and it’s not quite ready yet from what I can tell. Installed ubuntu touch but realized I needed a sim card adapter. Got one in but haven’t messed with it. May do that today if my other project goes well or I want to switch focus.

Also want to check out Postmarket and Phosh as well as xfce.

We, at Manjaro ARM, have just released a new image for the PinePhone and are very interested in hearing what you guys think.

It’s still alpha stage, but we working hard to get it right. :slight_smile:


Hey there @Strit I’ve just downloaded and flashed the Alpha4 image and will give it a test later this week! Thanks for chiming in here.

1 Like

I’m running it right now seems to be running fine also the time zone seem to be working lol but then rebooted it seem to revert back to utc .