Either I'm doing somethinf wrong or Snap is just stupid

I’ve been running out of space on one of my partitions and I found out that one of my snap applications I don’t even use takes 11GB of space. Let’s remove it.

I run snap list to see how to use it – there’s remove – great, let’s run it.

sudo snap remove brave and I get the message
save data of snap "brave" in automatic snapshot set which takes long while and fails, likely because I don’t have space to save the thing and application doesn’t seem to let remove package without it.

Search for solution on the internet doesn’t help as “snap” returns results mostly for “snapchat” and when I force it to skip entries with “snapchat” and try looking for problem with snapshot, of course I get results about screencap taking software.

So it looks like with Snap, I can’t free myself some space, because I don’t have enough space. Either that or removing packages just doesn’t work.


Moar like



1 Like

I’d try snap remove brave --purge. That way it won’t save the app’s data snapshot. I’ve never had an issue like this, but that might work.


It worked. I just wish there was some kinda information about it when remove failed.

So file a bug / suggestion with the Snap team, I’m sure they’ll fix it.