Dangers of everyone using that Chrome/Chromium crap

So look at these screen shots I took while visiting this site as a couple examples

Old Edge browser

Firefox version 81.

Notice the page is for “registering.”
Notice there is no means to register?
See all that blank white space on the right side?
Turns out it is not blank space at all.

While, I do not have anything Chromium, but others using Chrome says there are text boxes for entering information, and submitting your registration.

I have also tried using GNOME Web, and still the same result.

I do not have a a Mac, so unable to try if Safari has the same issue.

Here is the site:

Come on people, stop using that Chromium crap. It is giving Google too much control over the web.

Safari on Left, Chromium on right.

Firefox on left, Chromium on right.

dead on FF full window

I can’t reproduce your problem.

Thanks! I will have to check this out

The form requires javascript from app-sj14.marketo.com to generate. As marketo.com is a known advertising/tracking domain it’s blocked by popular ad blocking software including it’s subdomains.



That will do it. That was a fresh macOS install so I hadn’t had time to do up the usual extensions.

Edit: Nope even after uBlock Origin, HTTPS Everywhere, Privacy Badger, etc. I still get the form on Firefox even after emptying cache and cookies and the like.

Edit 2: Same results on Fedora too. I also see the form on GNOME Web v 3.38.0.

1 Like

Okay, I looked in PiHole, and yes it was blocking that. However, all is still not well.

Take a peek of the screen shot of GNOME Web.

Does GNOME Web have a Javascript console? If it does go to that URL again and paste this into the console:

let script = document.createElement('script');
script.src = '//app-sj14.marketo.com/js/forms2/js/forms2.min.js';
script.type = 'text/javascript';
script.onError = ()=>{alert('error')};
script.async = true;
script.onload = ()=>{alert('loaded')};

If you get a popup saying “error” it means something is blocking the page from loading the js file which rules out a code compatibility issue.

The screenshot is uMatrix.

I guess that’s a blindspot for uBlock Origin / Privacy Badger though PiHole seems to have it too.

It does have a console. Same key strokes as the others.

SiteSearch360 13.2.43 FAILED to initialize to #searchBox
There is no input element for the searchBox.selector “#searchBox”. Please update your ss360Config object.

That is it.

However, upon further investigation, GNOME Web has a built in Ad blocker. After turning it off, the form appeared. Not sure why they would go with such a spammy site. Do they have such a bad reputation?

Anyway, thanks all.

Though it appears instead they chose a spammy site to register people, I still stand by too many people using Chromium based browsers. It hurts us all in the end. Even Microsoft will be ending support for their Edge browser in April 2021 for favor of their “new” Chromium based Edge.


Again. My fourth screenshot was GNOME Web 3.38 with built in adblocker active and I still get the form.

1 Like

I am using 3.32, and it was for sure blocking. Maybe the updated one does less blocking? I am using Debian 10 , and they seem to be getting more behind the curve in updating to newer software.

I could reproduce the problem… no text boxes in Firefox but it worked in Chrome.

I then turned off Firefox’s advanced tracking protection and the site showed up properly.

Based on the other comments, I’d say the real danger is developers outsourcing core functionality to potentially shady third party service providers.


This is where I finally got the form to disappear in Firefox. Turning on “strict” protection. I went back after dropping back down to “standard” brings back the form. Opening the page in Incognito mode DOES block the form exactly as (now) expected. I’m a little concerned that enabling the usual suspects in the browser extensions doesn’t block this.
I’m a little more concerned that GNOME Web 3.38 still shows the form for me even with everything turned on.

Mystery solved.

A little more interesting is Raymond Hill created both uMatrix and uBlock Origin and he only used a block list on the former that includes that form’s domain.

It might be the ease of customization of uMatrix that makes it more friendly to stricter rules. Similarly someone with a PiHole is probably more comfortable with customization where the average Privacy Badger/uBlock Origin user may be more inclined to call the extension bad instead of customizing.

Just level 1 blocklist on custom for Trackers will do it.

The first thing I did to see the registering form because I have strict tracking protection enabled.
Actually it happens with a lot of forms on the web with Firefox.