304: Is It Okay To Use Linux In Virtual Machines Or WSL?

Any way you can use linux is a pretty good direction to fall.

From VMs to WSL, sometimes its nice to access linux to just get something done, and there is no shame in that.

Our laptops are pretty locked down at work, mostly for IT upkeep reasons, but far too often I find myself just needing a terminal or that one application that only runs on linux. I was hoping that WSL would allow me this freedom, but our IT department has yet to approve my request. So what do you do when VMs AND WSL are not an option?!?

(You get a pinebook and use linux ANYWAY.)

Great episode, and I’m jealous of the new HEAVY keyboard! It looks fantastic, and can’t wait to see a production model in person.

I’m just worried my thumbs might not be strong enough to handle the split-space bar. :stuck_out_tongue: :stuck_out_tongue: Because if I get one, I’m going to customize it so that it will only enter a ‘space’ if BOTH of them are pressed… Forget security. No one else will WANT to use my computer! :crazy_face:

1 Like

I am new to listening to Destination Linux (I started at 301 -304, & am working my way back). Enjoyable & informative.

In 304 you discussed wsl, which intrigued me, as I have windows 10 & wanted to try it. (I have some programs which will not run on my Linux machine.)

I tried following the instructions, but had to download it from the store. I tried to invoke it, but (even after several re-starts) I keep receiving a message that it needs an “optional component”, which I cannot find. I downloaded Ubuntu from the store, but cannot run it, as the error is:
WSLRegisterDistribution failed with error:0x80004002
Error: 0x80004002 No such interface supported.

Any clues for me?

Thanks for an interesting show.

1 Like

I believe (in my limited knowledge) you need to open a windows terminal (Command Shell) and execute something similar to the following:

wsl --install -d Ubuntu

This requires Admin-level privileges on my work computer (the only Windows box I typically see) and may/may not on a personal computer.

Keep us posted on how it works out for you. In particular, there is a package for Linux “speedtest-cli” that I like to use, and if it runs in WSL, I could really find that handy.

1 Like

Thanks for the feedback. I went into Powershell & typed the command, but it still stated that I need the “optional component”. I uninstalled the wsl I had downloaded from Microsoft & tried the install command in Powershell; it did not recognize wsl at all. I reloaded wsl & received the same responses as noted.

Somehow something is flaky.

I appreciate your assistance.

1 Like

Good show and yeah, VM’s should only be used to test stuff or for isolation purposes. That goes for pretty much any OS.

Interesting to hear zdne’ts take on Linux difficulty, but I honestly cannot take such articles seriously when they completely omit Debian from it. Sadly, this is a trend with tech journalism when it comes to Linux and Debian is just thought of as unsexy. Which is a shame because as a beginner distro it is very easy to install and use.

Us experienced users are obsessed with the latest and greatest, but for most computer users they just want something that works when they turn on their computer, and Debian is a very consistent experience even through major upgrade.

Y’all have a nice :christmas_tree:

1 Like

Do you get the same error message in the command prompt? (Not powershell)

Windows Key > “cmd” [enter]

I, personally, think yes. As much as I love Linux, if a person doesn’t have learning Linux as a priority, they shouldn’t be judged for that, and having it in a VM will ensure that they can remain comfortable with whatever OS they’re on while being able to learn Linux at their own pace.

I have Windows running in virtual machine for my iOS devices and Halo games. While Infinite works now, Master Chief Collection won’t collect achievements without EAC.